Ticket #7919 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

[IE] Creating link without focus inside body creates it inside host document

Reported by: Saare Owned by:
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.6.1
Keywords: Cc: satya_minnekanti@…

Description

In IE, clear the cache and open the AJAX sample. Without focusing the editor, click on the link icon. Insert a URL and hit OK.
Note that the link is inserted at the top of the sample (inside the <h1> really), and a JS error is thrown:

Message: 'null' is null or not an object
Line: 1568
Char: 4
Code: 0
URI: _source/core/dom/range.js

Does not occur in 3.6.

Change History

comment:1 follow-up: ↓ 4 Changed 3 years ago by Saare

Supposed to be fixed by #7904.

comment:2 Changed 3 years ago by satya

  • Cc satya_minnekanti@… added

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

I could reproduce it on IE9 only and very occasionally, so I could not find the revision. It works on 3.6 but it doesn't always work on trunk.

On IE8 - everything seems to be fine.

On IE7 - JS error pops out: Message: Invalid argument
Line : 174
node.$.parentNode.insertBefore( this.$, node.$ );
URI: /_source/core/dom/node.js
This error has occurred from CKEditor 3.5.3 rev [6586]
Not sure if there should be a new ticket reported for this?

On IE6 I couldn't open dialogs but this is a different issue reported in #7922

comment:4 in reply to: ↑ 1 Changed 3 years ago by garry.yao

Replying to Saare:

Supposed to be fixed by #7904.

This should not be related to #7904.

comment:5 Changed 3 years ago by Saare

  • Status changed from confirmed to closed
  • Resolution set to fixed

Had been fixed by #7904.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy