Opened 6 years ago

Closed 6 months ago

Last modified 3 months ago

#7982 closed Bug (fixed)

Multi-level lists get split into smaller ones

Reported by: j.swiderski Owned by:
Priority: Normal Milestone: CKEditor 4.6.0
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: Cc: satya_minnekanti@…

Description

  1. Open Ajax sample
  2. Paste the list from the attached file
  3. See that it gets split into several smaller lists.

This worked till version 3.5.2 for all browsers except Firefox (3.6 and 4). From version 3.5.3 rev [6616] list gets split in all browsers (except FF3.6 as it never worked and will work there).

Attachments (2)

lists.doc (41.0 KB) - added by j.swiderski 6 years ago.
lists_and_desc.doc (41.0 KB) - added by j.swiderski 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 6 years ago by satya

  • Cc satya_minnekanti@… added

comment:3 Changed 6 years ago by garry.yao

  • Status changed from confirmed to pending

It's caused by flipped "mso-list" indicators on list items:

<p class="MsoNormal" style="margin-left:18.0pt;text-indent:-18.0pt;mso-list:l0 *level2* lfo1;
tab-stops:list 18.0pt">item2</p>
<p class="MsoNormal" style="margin-left:36.0pt;text-indent:-18.0pt;mso-list:l1 *level1* lfo2;
tab-stops:list 36.0pt">item21</p>

We need to investigate how this invalid structure is composed in Word which doesn't looks like an ordinary case.

comment:4 Changed 6 years ago by garry.yao

  • Status changed from pending to confirmed

Changed 6 years ago by j.swiderski

Changed 6 years ago by j.swiderski

comment:5 Changed 6 years ago by j.swiderski

I have added new file with description how this list was created.

comment:6 Changed 6 years ago by j.swiderski

During reproduction I have found another problem. It is reported here #8103

comment:7 Changed 5 years ago by j.swiderski

Other tickets caused by [6616] revision: #8136, #8516, #8780

comment:8 Changed 3 years ago by fredck

  • Component changed from Core : Lists to Plugin : Paste from Word

comment:9 Changed 6 months ago by Tade0

  • Resolution set to fixed
  • Status changed from confirmed to closed

Fixed with new Paste From Word plugin in 4.6.0.

comment:10 Changed 6 months ago by Anna

  • Milestone set to CKEditor 4.6.0

comment:11 Changed 5 months ago by satya

This issue is not properly fixed. Tested again on nightly for 4.6 List indentation does not show properly after paste. Pls re-open this defect

comment:12 Changed 3 months ago by j.swiderski

@satya - while the file from list doc really produces the problem, I haven't been able to re-create such list and get the same result.

I was creating nested lists in Word using increase indent or tab, increasing indent on whole list and changing the list type. Visually list looked the same like in the example but it never produced any errors. Looking at the clipboard HTML the levels were also ok and not like it was mentioned in comment:3 for the original list.

Also this particular list produces problems in other editors. Namely there are two lists pasted.

I think that list from that file was a special case. Are you able to reproduce the problem creating list from scratch. I yes, could you provide sample docx file and tell me how have you created such list?

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy