Ticket #8005 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

CKEditor.NET 3.5.3/CKEditor 3.6: editor not displayed after postback in DynamicData site

Reported by: dpomt2 Owned by: kaga
Priority: Normal Milestone:
Component: Server : ASP.Net Version: 3.5.3
Keywords: Cc:

Description

A small and eady to reproduce VS2010 web site is attached to this tickets. Follow instructions written in test.aspx.

I will also attach a screenshot that shows the issue.

Attachments

ckeditor_bug_screens.jpg (293.6 KB) - added by dpomt2 3 years ago.
Screen showing the issue
repro.zip (662.1 KB) - added by dpomt2 3 years ago.
VS2010 web site taht easily demonstrates the issue
ko.html (19.2 KB) - added by dpomt2 3 years ago.
html dom saved directly after issue occured
repro.2.zip (277.8 KB) - added by dpomt2 3 years ago.
requested files
8005and8089.patch (3.8 KB) - added by kaga 3 years ago.
repro_screen_new.jpg (254.6 KB) - added by dpomt2 3 years ago.
Screen displaying issue after usage of patch (as mentioned in last comment)

Change History

Changed 3 years ago by dpomt2

Screen showing the issue

Changed 3 years ago by dpomt2

VS2010 web site taht easily demonstrates the issue

comment:1 Changed 3 years ago by dpomt2

to reproduce, it is necessary to put the ckeditor directory to the root folder of the extracted attached repro.zip (ckeditor dir was too huge to include in zip)

comment:2 Changed 3 years ago by j.swiderski

You think it would be possible to provide me with generated HTML page (with JS and CSS files)?

I want to make sure if this is not "clean"(read not CKEditor for .NET) CKEditor issue.

Changed 3 years ago by dpomt2

html dom saved directly after issue occured

comment:3 Changed 3 years ago by dpomt2

sure, see attachment I have just added to this ticket.

comment:4 Changed 3 years ago by j.swiderski

Actually I meant the page before the issue occurred.

A simplified test case - Complete generated HTML page with CSS and JS files that will allow me to test this issue with out any .NET

comment:5 Changed 3 years ago by dpomt2

Don't know how I could easily create this for you. Would it help you if I give you remote access to a VM that allows you to easily see, reproduce and debug the issue?

comment:6 Changed 3 years ago by j.swiderski

After you click ‘auswahlen’ - this is just before the error. All you have to do is click 'Edit' to get it. I assume that clicking 'Edit' is executed on browser side so maybe I will be able to do something with it.

You can just save the page from Firefox browser as a complete page. It should be saved as html with css, js and images.

Changed 3 years ago by dpomt2

requested files

comment:7 Changed 3 years ago by dpomt2

unzip the repro.zip, two folders will be extracted. the "repro" folder contains the files right before the issue occurs (after click at "auswählen". the "repro2" contains all files after clicking new (the working test case). Within the "repro" folder, there is no ckeditor.js. It seems that the ASP.NET postback when clicking on "auswählen" does not load the necessary ckeditor js.

comment:8 Changed 3 years ago by j.swiderski

I have asked you for these files to exclude the possibility that this is clean CKEditor issue.

From what you have showed me it seems that it might be CKEditor integration for ASP.NET problem.
I have written "might" because of what you have written in your last post:

Within the "repro" folder, there is no ckeditor.js. It seems that the ASP.NET postback when clicking on "auswählen" does not load the necessary ckeditor js.

It seems at least to like the root cause of the problem. Could it be something in your application that is causing ckeditor.js not being loaded?

Changed 3 years ago by kaga

comment:9 Changed 3 years ago by kaga

  • Status changed from new to review
  • Owner set to kaga

This patch contains fixes for two tasks - because it modifies the same lines.

comment:10 Changed 3 years ago by dpomt2

@j.swiderski: it is not my app. I am sure since it works with an alternative server control for ckeditor (http://cksource.com/forums/viewtopic.php?f=11&t=15882&start=170&sid=925c1b8fc724137edec55af791229e80).

comment:11 Changed 3 years ago by dpomt2

@kaga: this fix does not work for my app as you can easily verify with the repro solution attached to this ticket.

I have just downloaded 3.6.1 of CKEditor and CKEditor.NET control, added the supposed patch and recompiled. I now have the following misbehavior: after clicking at select (ajax postback), the first ckeditor isn't displayed at all (even textbox is removed), the 2nd textbox contains html code but no ckeditor. I will attach a screenshot later.

Changed 3 years ago by dpomt2

Screen displaying issue after usage of patch (as mentioned in last comment)

comment:12 Changed 3 years ago by wwalc

@dpomt2 - could you double check it again? Make sure that you're using the correct version of CKEditor.NET.dll. I have recompiled CKEditor 3.6.1 with the 8005and8089.patch applied, reopened the sample project (repro.zip) and everything works fine for me now (tested on IE8, FF 3.6.18, Chrome 13).

Is it possible that you forgot to copy ckeditor (the editor) into "ckeditor" folder when trying to reproduce it again?

comment:13 Changed 3 years ago by dpomt2

Hi wwalc, thanks for testing with my repro solution. i have just re-compiled CKEditor.NET.dll with the patch and recopied it to the target project and it now works like a charme. I did not forget to copy ckeditor 3.6.1 prior to testing but I assume I did copy the CKEditor.NET.dll to the wrong target directory.

Thanks to kaga for fixing this showstopper :)

comment:14 Changed 3 years ago by dpomt2

This ticket could be closed as fixed as soon as mentioned patchset is included into delivery.

Last edited 3 years ago by dpomt2 (previous) (diff)

comment:15 Changed 3 years ago by wwalc

  • Status changed from review to review_passed

dpomt2 - thanks for checking the patch one more time. R+, looks good to me as well.

comment:16 Changed 3 years ago by wwalc

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7259].

comment:17 Changed 3 years ago by bdeco1

I am having this same issue with the CKEditor, I recently checked out a copy from http://svn.ckeditor.com/CKEditor.NET/trunk/, and noticed that it has the fix already in it and I wanted to compile the CKEditor.NET project to a DLL, how do I do that?

also I noticed that patch has a msajax.js file in it does that get compiled in with it or is there something else I need to doo with that?

sorry for being noobish

comment:18 Changed 3 years ago by wwalc

@bdeco1 - an updated official release of CKEditor for ASP.NET will be probably available in 48h.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy