Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#8016 closed Bug (fixed)

Chrome: Flash content not visible in page preview.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version: 3.0
Keywords: Chrome IBM Cc: satya_minnekanti@…

Description

  1. Open flash dialog
  2. Paste url to flash or image
  3. Press ok
  4. Press page preview button.

Result: Neither image nor flash is visible on page.

Images are invisible from CKEditor 3.6.1 rev [6929]

Flash is invisible from CKEditor 3.0

Attachments (2)

8016.patch (645 bytes) - added by garry.yao 4 years ago.
b.swf (580.7 KB) - added by j.swiderski 4 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed

Changed 4 years ago by garry.yao

comment:2 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:3 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:4 Changed 4 years ago by garry.yao

  • Owner garry.yao deleted
  • Status changed from review_passed to new

WFM with chrome12.0/win7 on trunk.

comment:5 Changed 4 years ago by krst

Confirmed (not working) under chrome 12/winxp on trunk

comment:6 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed

At first I wanted to close this issue as DUP of #6323 but since patch has been added to this one, I have decided to leave it and close the #6323

The proper message should sound: Flash content not visible in Page and Dialog Preview.

When I say flash content I mean *.swf and *.jpg files.

Flash and picture files are not visible in Chrome in Dialog Preview from CKEditor 3.5.1

Flash files are not visible in Page Preview form CKEditor 3.0
Picture files were visible in Page Preview form CKEditor 3.5.3 to 3.6.1 rev [6928]. Rev [6929] has broken them again.

This issue doesn’t work under Win7 and Win XP but works under Ubuntu and Mac.

If you set wmode to transparent pictures and flash are visible again.

I have tested this issue with flash provided in #6323 http://img02.taobaocdn.com/tps/i2/T1bC4LXbxeXXXXXXXX.swf and on file attached to this ticked (b.swf)

Changed 4 years ago by j.swiderski

comment:7 Changed 4 years ago by satya

  • Cc satya_minnekanti@… added
  • Keywords IBM added

comment:8 Changed 4 years ago by garry.yao

  • Milestone set to CKEditor 3.6.2
  • Resolution set to fixed
  • Status changed from confirmed to closed

Fixed with [7194].

comment:9 Changed 4 years ago by usami

This issue did not fixed at ckeditor3.6.2. There is still the same issue at demo site too.

comment:10 Changed 4 years ago by j.swiderski

Seems good to me. The only problem I see are problems with dialog's preview which where reported in #7743

comment:11 Changed 2 years ago by pjasiun

I removed this hack developing MathJax widget (#10664). We don't need it anymore cause in newest Chrome everything is fine and it was the reason of some problems with javascript in preview.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy