Opened 5 years ago

Closed 5 years ago

#8132 closed Bug (fixed)

[IE9] When an <a> contains a <br>, when you click the <br> the <a> changes to <a name="cke_range_marker">

Reported by: jonathonsim Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.5.4
Keywords: IE9 Cc:

Description

In ckeditor 3.6.1 and also the latest nightly demo, eg http://nightly.ckeditor.com/7084/_samples/replacebyclass.html

If you have HTML where a link contains a break, like so:

<a href="http://google.com">In IE9 click the end of this line -&gt;<br />
	then the link turns into an anchor</a>

When you click on the end of the line containing the <br>, your link will immediately change to an anchor. The source is changed to this:

<p>
	<a name="cke_range_marker">In IE9 click the end of this line -&gt;<br />
	then the link turns into an anchor</a></p>

I have tested this with IE8, which doesn't have this problem. Other browsers (firefox, chrome etc) do not either.

Attachments (1)

8132.patch (1.1 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by j.swiderski

  • Keywords IE9 added
  • Status changed from new to confirmed
  • Version changed from 3.6.2 (SVN - trunk) to 3.5.4

Reproducible from CKEditor 3.5.4 (although in 3.5.4, clicked link looked like text).

When clicking at the end of the line the JS error is thrown:
Message: DOM Exception: NOT_FOUND_ERR (8)
Line:760[[BR]] URI: /_source/plugins/selection/plugin.js

comment:2 Changed 5 years ago by finalweb

  • Version changed from 3.5.4 to 3.6.2

Is there any update on this issue? It affects all users in the 32bit version of IE 9. It exists in 3.6.2 as well.

comment:3 Changed 5 years ago by j.swiderski

  • Version changed from 3.6.2 to 3.5.4

Version filed is used to indicate when the problem occurred for the first time and not last. Please do not change this value.

comment:4 Changed 5 years ago by brshaffer

Any activity on this? I have some irate customers due to this bug, would love to see a fix.

comment:5 Changed 5 years ago by fredck

This issue is caused by [6624].

Changed 5 years ago by garry.yao

comment:6 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:7 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.6.3
  • Status changed from review to review_passed

Nice finding.

comment:8 Changed 5 years ago by garry.yao

Fixed with [7366].

comment:9 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy