Ticket #8142 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Application landmark taking focus to Tool bar instead of Editor body after visiting toolbar.

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.2
Keywords: IBM VendorFix Cc: damo, tmonahan

Description

To reproduce the defect

  1. With JAWS On, open CK Editor sample, navigate in to editor body
  1. Press Alt+F10 to navigate in to toolbar.
  1. Press Esc to come out out of toolbar and go in to editor body.
  1. Press tab 3 times to come out of editor body & navigate to CK Source link.
  1. Press Ctrl + Insert + ; to open landmarks dialog
  1. Select Application landmark in the dialog and press Tab to go to Application landmark

Expected Result: Focus goes to editor body.

Actual Result: Focus goes to first enabled element in the tool bar.

This issue was some what related to #5955

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.3

comment:2 Changed 3 years ago by garry.yao

  • Status changed from confirmed to new

I don't think the landmark role has anything to do with browser focus, it instead navigate the screen reader's visual cursor to the assigned element.

comment:3 follow-up: ↓ 5 Changed 3 years ago by damo

The question here is whether the editor is contributing to the focus management in some way. We have not ruled out that this could be an issue with JAWS.

Garry is correct that the application landmark is being used to navigate the virtual cursor. If JAWS is working properly, after hitting Tab the user should be navigated to the next focusable item inside the application landmark. Yet we know that the toolbar buttons have onFocus logic to push focus into the editing body rather than into the toolbar.

An interesting observation is that if the toolbar had not been activated by the user at all, using the application landmark to navigate to the editor and hitting Tab always brings the focus into the editing area. If on the other hand, the toolbar had already been navigated at least once prior to using the application landmark, focus always goes to the toolbar first. This inconsistent behavior is the real problem.

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.3 to 3.2

The correct CKE version from which problem has started occurring should be 3.2

Because of inconsistency that @damo has pointed out I think that this ticked should be confirmed after all.

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 3 years ago by fredck

Replying to damo:

An interesting observation is that if the toolbar had not been activated by the user at all, using the application landmark to navigate to the editor and hitting Tab always brings the focus into the editing area. If on the other hand, the toolbar had already been navigated at least once prior to using the application landmark, focus always goes to the toolbar first. This inconsistent behavior is the real problem.

That's an interesting point, in fact, which makes me think that this may be an issue with JAWS. The things is that we don't do anything special when moving the focus to the toolbar.

Is it something that FS can confirm to us?

comment:6 in reply to: ↑ 5 Changed 3 years ago by damo

Replying to fredck:

That's an interesting point, in fact, which makes me think that this may be an issue with JAWS. The things is that we don't do anything special when moving the focus to the toolbar.

Is it something that FS can confirm to us?

Agreed, so long as CKEditor isn't managing the focus here, there is scope for FS to help investigate this.

comment:7 follow-up: ↓ 9 Changed 3 years ago by garry.yao

No, we did somehow managed the focus there as a workaround for an old issue that we've discovered with JAWS back in #3052.

comment:8 Changed 3 years ago by garry.yao

  • Keywords VendorFix added

comment:9 in reply to: ↑ 7 Changed 3 years ago by damo

Replying to garry.yao:

No, we did somehow managed the focus there as a workaround for an old issue that we've discovered with JAWS back in #3052.

If editor.toolbox.focusCommandExecuted is not reset correctly, it will stop the button from pushing focus to the editor:

if ( !editor.toolbox.focusCommandExecuted ) {
    editor.focus();
}

This is why we are seeing different behavior before focusing in the toolbar and after it.

comment:10 Changed 2 years ago by satya

This was fixed with JAWS 13.0 & FF7.0.. Please close the ticket

comment:11 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

Yes, seems to be fixed with JAWS 13.0 & FF7.0.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy