Ticket #8181 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Incorrect background color setting while changing font size.

Reported by: krst Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.0
Keywords: Cc:

Description

  1. Set text background color to background-color:#0000ff or any other.
  2. Type few characters and press space
  3. Change font size to bigger one
  4. Repeat step 2 and 3 until font size 72

Expected

Each part of text should have its own background, height of background is set according to font size.
Example:

<p>
	<span style="font-size:24px;"><span style="background-color:#0000ff;">asd </span><span style="font-size:36px;"><span style="background-color:#0000ff;">asd </span><span style="font-size:72px;"><span style="background-color:#0000ff;">asd </span></span></span></span></p>

Actual

<p>
	<span style="background-color:#0000cd;">asd<span style="font-size: 16px;"> asd<span style="font-size: 20px;"> asd<span style="font-size: 24px;"> asd <span style="font-size: 72px;">asd</span></span></span></span></span></p>

Attached screen

additional info

I was able to reproduce this under FF since cke30, under webkit browsers since 3.5.3 (afer "setting style on colapsed selection" was solved)

Attachments

zrzut_ekranu-18.png (44.6 KB) - added by krst 3 years ago.

Change History

Changed 3 years ago by krst

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

Reproducible in all browsers from CKE 3.0.

comment:2 Changed 3 years ago by j.swiderski

This issue was duplicated in #8250.

comment:3 Changed 3 years ago by krst

First reported in #2675

comment:4 Changed 3 years ago by j.swiderski

Duplicate was reported in #8437

comment:5 Changed 3 years ago by j.swiderski

From the ticket #8437 you can see that same thing can be reproduced when pasting from Word.

IMO if CKEditor could wisely switch spans from

<span style="background:lime;">
       <span style="color:white;">
           <span style="font-size:36.0pt;">WORD</span>
       </span>
</span>

to (size around background color)

<span style="font-size:36.0pt;">
    <span style="background:teal;">
         <span style="color:white;">ABC</span>
</span>

Problem would be solved .

comment:6 Changed 3 years ago by j.swiderski

Just a note - #3599 says that this issue is supposed to be fixed.

comment:7 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

DUP of #5503

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy