Ticket #8188 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Internet Explorer 9 inserts sab="#" tags

Reported by: webtechnician Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: IE9 Cc:

Description

Using FCK Editor version 2.6.3 on a Drupal install with the FCK Editor Module version 6-x2.1. Everything works fine with every browser except IE 9. In Internet Explorer 9 (version 9.0.8xxx) the editor is now inserting the sab="#" tag. The # is always some arbitrary number that it picks then begins counting from there with every element. So p sab="1" br sab="2" etc.

I had previously also had trouble getting the About section to display without locking up but that was resolved with the <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" /> fix. This does not resolve the sab="" situation unfortunately.

Is there any way to get rid of this sab tag? Is anyone experiencing the same issue with a newer version?

Attachments

ie9bug.jpg (47.2 KB) - added by webtechnician 3 years ago.
Sab="701"

Change History

Changed 3 years ago by webtechnician

Sab="701"

comment:1 Changed 3 years ago by webtechnician

  • Keywords sab, ie, internet explorer, 9 added

comment:2 Changed 3 years ago by j.swiderski

  • Keywords IE9 added; sab, ie, internet explorer, 9 removed
  • Status changed from new to pending

We have run FCKeditor version 2.6.3 and 2.6.6 on Drupal but no "sab" tags were added.

Could you provide us with more information on this one?

A step by step scenario describing how to reproduce the issue or a sample test page showing the problem.

Also could you tell us if you are using default or custom configuration settings? If custom then could you provide them as well?

comment:3 Changed 3 years ago by webtechnician

The sab tags seem to be added in when you allow font format of p (normal) as an option for individuals to select. If someone selects the p (normal) option they would be greeted with this error message: Line: 36 Character: 178 Code: 0 Error Message: Unexpected call to method or property access. URL: /sites/all/modules/fckeditor/fckeditor/editor/js/fckeditorcode_ie.js

Upon removing normal as an option and limiting it to only h2, h3 both the sab tags and error message went away.

comment:4 Changed 3 years ago by j.swiderski

p (normal) option is the default option for paragraph format. We have tested your case with this option set, tried to change it to heading1 and go back to paragraph but again, nothing unusual happened.

Could you provide us with a sample HTML file in which this issue is reproducible?
Perhaps there is something else like: page is running in quirks mode, there is some other non-standard tag that is causing this?
Could also you tell us what other modules for Drupal are you using – perhaps they are the source of the problem.

NOTE: I have to tell you that FCKeditor is no longer supported and we ask you for all this information to reproduce the issue in FCK and see if it also occurs under CKeditor. If it occurs than the bug is valid (but issue will be fixed only under CKeditor), if not than issue is treated as an invalid and you tell our users to upgrade.
If you want you can always check this issue under CKEditor for Drupal and tell us if it occurs there. If not than perhaps it wouldn’t be such a bad idea to upgrade.

Waiting for your feedback.

comment:5 Changed 3 years ago by webtechnician

I unfortunately don't even know where to start to create a sample html file of what is going on.

Here are the steps I just used to reproduce -

  1. Go into FCKEditor settings and set cleanup and output font formats to p;h2;h3,etc and click save
  2. Open up your IE 9 browser and go to edit any piece of content
  3. Switch to plain text to see the sab="" tag

The format will read blank across the top of the screen. Selecting "normal" will actually cause an error message to appear:

"Line: 36 Character: 178 Code: 0 Error Message: Unexpected call to method or property access. URL: /sites/all/modules/fckeditor/fckeditor/editor/js/fckeditorcode_ie.js"

Removing p as an option in the fckeditor settings removes both the js error & the sab tags.

I'm running a good deal of modules so it would be hard to pinpoint this to any particular module. Tao / Rubik is the admin theme running the site.

comment:6 Changed 3 years ago by j.swiderski

Once again we have checked it and could not find any thing under CKeditor nor FCKeditor. Seems that everything you have mentioned so far is not causing this problem.

We have a suspicion that one of your modules can be causing this. You think it would be possible if you check all your modules one by one to see which one (if any) is causing this?

comment:7 Changed 3 years ago by j.swiderski

@webtechnician have you got any updates regarding this issue?

comment:8 Changed 3 years ago by webtechnician

Updated to CK Editor version 6-x1.5 on Drupal, using CK editor version 3.61

Same sab code gets inserted into the html using an Internet Explorer 9.08 build when p is available as a possible format example.

Also, this may be more of a drupal module issue, but when trying to do a <br> return a new line break isn't created. Shift return for a <p> tag does work however.

comment:9 Changed 3 years ago by webtechnician

The problem is caused by an add on for Internet Explorer called "Simple Adblock" or "Simple Adblock class." Disabling it fixed the problem for me (I've seen some other forums around where people had similar problems so hopefully now others will know where to look)

comment:10 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid

Good to know the solution for "inserted sab="#" tags in Explorer 9".

Anyway as you have mentioned this is because "Simple Adblock" is causing this and not CKEditor. I hale to close this isssue as an invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy