Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#82 closed Bug (fixed)

EMBED tag inside OBJECT is removed by IE

Reported by: fredck Owned by:
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: SF Confirmed IE Cc: olliemaitland@…, aussi@…, jupiter_one@…

Description

When adding a flash object through the SOURCE view and saving a page with IE it strips out the <embed> tag. This leaves the flash to work in IE but not in Firefox (1.0).

When editing in Firefox - however - the <embed> tag remains and all is well.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1082447&group_id=75348&atid=543653

Change History (11)

comment:1 Changed 10 years ago by fredck

I confirm this is still a problem in 2.1.1. Although there is now a dialog for inserting Flash, if you insert <embed> and <object> tags using source mode, say to add a QuickTime movie, IE will strip out the <embed> tags.

Moved from SF. Original commenter: aussi

comment:2 Changed 10 years ago by fredck

  • Cc olliemaitland@… @… added

Version 2.2 also do that :(

Moved from SF. Original poster: Anonymous

comment:3 Changed 10 years ago by fredck

I am finding this to be a problem as well. By default, the 'Insert Flash Object' toolbar option uses an <embed> tag only, as opposed to an <object> tag with an <embed> tag within it. When this page is served up in the setupI run (it is loaded into an <iframe> surrounded by navigation controls and banners), and when that window is resized, the flash objects flicker and disappear and cause all sorts of problems. When the same page uses <object> tags, it resizes smoothly and there's no problem. But then you have the issue described in this bug with the editor not displaying the flash object properly anymore.

Hope a solution presents itself.

bj.

Moved from SF. Original poster: jupiter_one

comment:4 Changed 10 years ago by fredck

https://sourceforge.net/tracker/index.php?func=detail&aid=1530003&group_id=75348&atid=543653 has been marked as duplicate of this bug

Moved from SF. Original poster: alfonsoml

comment:5 Changed 10 years ago by fredck

  • Cc aussi@… jupiter_one@… added; @… removed

comment:6 follow-up: Changed 10 years ago by alfonsoml

As noted in https://sourceforge.net/tracker/index.php?func=detail&aid=1661658&group_id=75348&atid=543653 now the behavior is the inverse: now the object is removed and the embed is preserved for both Firefox and IE.

Also thanks to changeset [147] now it's possible to include the code provided by youtube for example and the flash placeholder appears.

I don't know why the object doesn't appear now in IE and it would be interesting to know, but at least now editing the object+embed in IE doesn't mean that it no longer works in Mozilla.

comment:7 in reply to: ↑ 6 Changed 9 years ago by fredck

Replying to alfonsoml:

I don't know why the object doesn't appear now in IE and it would be interesting to know

I've created #359 and explained it there.

comment:8 Changed 9 years ago by fredck

  • Keywords Confirmed IE added
  • Milestone set to FCKeditor 2.5
  • Version set to SVN

This problem is the complete opposite of #359, but the solution could be the same.

Looking at MS's documentation, here is what we have:

"If an object fails to instantiate for any reason, the HTML inside the OBJECT element is rendered"

But, if the object is successfully instantiated, "the HTML inside the OBJECT element" is completely ignored in the DOM tree. In other words, the <embed> element simply doesn't exist.

As explained in #359, a solution for it would be removing the <object> tag when loading the WYSIWYG view and placing it back when submitting or switching to source. To do that, for now, just add the following to the fckconfig.js file:

FCKConfig.ProtectedSource.Add( /<object[\s|\S]+?<\/object>/gi ) ;

We'll be much probably handle this internally in the editor code, not requiring it to be included in the configuration file. So, I'm leaving this ticket opened until the fix is not available.

Does this fix seams reasonable?

comment:9 Changed 9 years ago by fredck

  • Milestone changed from FCKeditor 2.5 to FCKeditor 2.4.3
  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [327].

Click here for more info about our SVN system.

comment:10 Changed 8 years ago by starman

We need some help implementing this plugin. Please let me know if someone is available to work with us on an hourly rate. Many thanks.

comment:11 Changed 8 years ago by alfonsoml

This is not a plugin, but a direct change to the FCKeditor source, if you're updated then it should work automatically.

If you need help about any plugin then you can ask in the FCKeditor forums or to the author of the plugin.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy