Ticket #8214 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Invalid table colspans break row insert

Reported by: mattleff Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version:
Keywords: Cc:

Description

Reproduce steps:

  1. Open demo
  2. Paste the following in source:
    <table>
    	<tbody>
    		<tr>
    			<td colspan="4">
    				First row</td>
    		</tr>
    		<tr>
    			<td>
    				1</td>
    			<td colspan="2">
    				2</td>
    		</tr>
    	</tbody>
    </table>
    
  3. Click source again to leave source mode.
  4. Right click table and insert row before or after.

Expected result

The row will be inserted before or after, respectively.

Actual result

No row is inserted and in webkit browsers a JS error is thrown:

Uncaught TypeError: Cannot read property 'rowSpan' of undefined

Browsers

This was tested with Chrome 12, FF5, and Safari 5.1.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #7996

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy