Opened 4 years ago

Closed 21 months ago

#8395 closed Bug (fixed)

IE6-10: Clicking enter after selecting table, page-break or hr causes JS error

Reported by: ananthand Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 3.0
Keywords: IE Cc:

Description (last modified by j.swiderski)

Table

  1. Clear editor contents
  2. Click on/Select the table (so that you could see resize squares)
  3. Press ENTER key

Page-Break

  1. clear the page
  2. type some character + press ENTER + press page_break
  3. press Ctrl+A
  4. press page_break again.

Alternative STR:

  1. Click anywhere in the "Little Red Riding Hood" page and press page_break.
  2. press Ctrl+A to select the whole page.
  3. Click again on the page_break.

Horizontal line

  1. clear editor contents
  2. insert <hr />
  3. set cursor at the beginning of paragraph that contains horizontal line - press cursor UP key (little cursor should be blinking at the beginning of line)
  4. press enter

Attachments (1)

getFirst_ScriptError.bmp (1.4 MB) - added by ananthand 4 years ago.
getFirst() is null or not an object

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by ananthand

getFirst() is null or not an object

comment:1 Changed 4 years ago by j.swiderski

  • Keywords IE added
  • Status changed from new to confirmed
  • Version changed from 3.6.2 to 3.0

Results for above TCs: JS error is thrown

IE9-IE10
Message: Unable to get value of the property 'insertBeforeMe
Line: 163
URI: /ckeditor/_source/core/dom/range.js

IE6-8
Message: 'getFirst()' in null or not an object
Line: 163
URI: /ckeditor/_source/core/dom/range.js

Reproducible in all versions of IE from CKEditor 3.0

Last edited 3 years ago by j.swiderski (previous) (diff)

comment:2 Changed 3 years ago by j.swiderski

  • Component changed from Core : Tables to Core : Selection
  • Description modified (diff)
  • Summary changed from Clicking enter after selecting table getting script error in IE8 to IE6-10: Clicking enter after selecting table, page-break or hr causes JS error

comment:3 Changed 3 years ago by j.swiderski

#7193 was marked as duplicate.

comment:4 Changed 3 years ago by j.swiderski

Same error but diffrent TC and different version #8800

comment:5 Changed 21 months ago by Reinmar

  • Resolution set to fixed
  • Status changed from confirmed to closed

I couldn't reproduce any of these issues on 4.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy