Ticket #8407 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

aria-setsize and aria-posinset incorrectly set on Styles drop-down

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Accessibility Version: 3.2
Keywords: IBM Cc: satya, tmonahan

Description

The items in the Styles drop-down do not have their correct aria-setsize and aria-posinset attributes set.

For example, when the selection is on a default paragraph and the Styles drop-down is displayed, the first item in the list has:
aria-posinset=5 and aria-setsize=21

These values should be:
aria-posinset=1 and aria-setsize=17

Attachments

8407.patch (1.1 KB) - added by garry.yao 2 years ago.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

But this set has 4 extra elements like "Image on the right" or "Borderless Table".

Yes they don't quite fit if you look that set has mainly elements from styles dropdown but is it causing any problems?

comment:2 Changed 3 years ago by damo

@j.swiderski The extra elements you mention are present in the DOM but not displayed in the list. The problem for screen reader users is that when entering the list and focusing on the first element, the screen reader will read "option 5 of 21" when in fact, it is option 1 of 17, because the other elements are hidden and not reachable. This gives the wrong impression that there are available options in the list before the first element.

Each time the list is displayed these attributes need to update to reflect the actual state of the list.

Although, the way that the combo is implemented, aria-posinset and aria-setsize might not be required at all. The list of options does not dynamically change its contents as the user navigates it and all available options are rendered at once. See the WAI-ARIA spec for further details: http://www.w3.org/TR/wai-aria/states_and_properties#aria-posinset and http://www.w3.org/TR/wai-aria/states_and_properties#aria-setsize.

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from pending to confirmed
  • Version set to 3.2

Didn't pay attention to that "5 of 21" when testing. Sorry.

Reproducible from CKEditor 3.2

Changed 2 years ago by garry.yao

comment:4 Changed 2 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

These two attributes are presented for guiding JAWS on old IEs, since not usable right now, let's see if screen reader behaviors well without it.

comment:5 Changed 2 years ago by fredck

  • Status changed from review to review_passed
  • Milestone set to CKEditor 3.6.3

Ok, it makes sense.

comment:6 Changed 2 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7367].

comment:7 Changed 2 years ago by garry.yao

The same change is missed on the color panel, post fixed with [7443].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy