Ticket #8409 (closed Bug: worksforme)

Opened 3 years ago

Last modified 2 years ago

Window scrolling on paste (cmd+v)

Reported by: ragnarfrosti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: Firefox Mac Cc: freddie@…

Description

Hi guys, I'm using CKEditor 3.6.2 and working in Firefox 6.0.2 (Mac OS X). When I paste (cmd+v) a text into the textarea of the CKEditor the whole window scrolls down (how much depends on the amount of text i paste) which means that every time I paste a piece of text to the CKEditor field I need to scroll back upp to be able to continue to work in the textarea.

This problem can be reproduced on your demo page (http://ckeditor.com/demo).

Attachments

Lorem ipsum dolor sit amet.doc (53.5 KB) - added by j.swiderski 3 years ago.
Firefox.png (123.5 KB) - added by j.swiderski 3 years ago.
ckeditor-8409.diff (1.1 KB) - added by clkao 2 years ago.

Change History

comment:1 Changed 3 years ago by ragnarfrosti

If this works for you, try to click outside the CKEditor area and inside the area again and paste the text, realized that it works sometimes...

comment:2 Changed 3 years ago by j.swiderski

  • Keywords Firefox Mac added
  • Status changed from new to confirmed
  • Version changed from 3.6.2 to 3.4.2

I have been able to reproduce this issue in Firefox from CKEditor 3.4.2.

To Reproduce:

  1. Copy contents form attached doc
  2. Open replacebycode or skins sample or ckeditor demo page in MAC
  3. Scroll down browser window a little bit just like it is shown in Firefox.png
  4. Copy contents from doc and paste them into editor few times using CMD+V.

Result: Usually on second paste the whole page scrolls down but I sometimes had to paste it at least five times to get result.

Changed 3 years ago by j.swiderski

Changed 3 years ago by j.swiderski

comment:3 Changed 3 years ago by jozefi

Same (or very similar) bug observed also on Chrome on Windows. After each paste editor scrolls to the bottom of the target paragraph. So if the whole text is single paragraph or div (happens when CKeditor config.forceEnterMode is set to false) it will scroll to the bottom of the page, alternatively to the pagraph's last line.

  1. Write or paste long article (just single paragraph, no other html tags).
  2. Scroll to the top of the article.
  3. Copy and paste any (small or big) piece of text somewhere to the beginning of the article.

See CKeditor scrolls to the bottom of the article every time.

Last edited 3 years ago by jozefi (previous) (diff)

comment:4 Changed 3 years ago by fbingha

  • Cc freddie@… added

comment:5 Changed 3 years ago by j.swiderski

I was not able to reproduce it anymore in latest Firefox 10.0.1. Can anyone confirm?

comment:6 Changed 3 years ago by j.swiderski

@jozefi I have moved your description to other ticket #8747 as this is different issue.

comment:7 Changed 3 years ago by fredck

  • Status changed from confirmed to closed
  • Resolution set to worksforme

I'm not able to reproduce this any more as well.

Changed 2 years ago by clkao

comment:8 Changed 2 years ago by clkao

  • Version changed from 3.4.2 to 3.6.6 (SVN - trunk)

this happens on trunk for me on chrome 24 / macosx. please reopen.

to reproduce: create a page large enough so the scrollbar shows. scroll somewhere in the middle, paste a small chunk of text and the editor will scrolled to have the newly pasted text aligned to the bottom of the editor.

attached is a patch to fix this.

comment:9 Changed 2 years ago by j.swiderski

  • Version changed from 3.6.6 (SVN - trunk) to 3.4.2

@clkao I have reported separate issue for your post #9554

comment:10 Changed 2 years ago by clkao

Hi,

My patch was missing a line: var win = doc.getWindow();

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy