Opened 4 years ago

Closed 22 months ago

Last modified 22 months ago

#8430 closed Bug (wontfix)

Id attribute get lost when hit backspace

Reported by: flavien Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc:

Description

Reproduced with internet explorer. Works fine in firefox. In source mode, inject this code :

<div id="body">
	<ul>
		<li>
			foo</li>
	</ul>
</div>

In wysiwyg mode, press enter after foo. Then press backspace, and go to source mode. The id attribute on the div is lost;

Thanks in advance.

Change History (6)

comment:1 Changed 4 years ago by j.swiderski

  • Keywords IE added; ie removed
  • Status changed from new to confirmed
  • Version changed from 3.6.1 to 3.0

comment:2 Changed 4 years ago by j.swiderski

Reproducible in all versions of IE.

From CKE 3.5.4 two paragraphs are created but this is due to #8419

<div>
	<ul>
		<li>
			foo</li>
	</ul>
</div>
<p>
	&nbsp;</p>
<p>
	&nbsp;</p>

comment:3 Changed 4 years ago by flavien

Is there any clue to resolve this problem ?

Thanks in advance if it can be solved quickly :).

comment:4 Changed 4 years ago by flavien

I apologize, it's a bug from IE. Go to that url http://vien.us/bad_ie.html. It's an iframe with a contenteditable attribute on the body. Do the same test as before. The id on the div disappears.

The ticket can be closed. Thanks for everything.

comment:5 Changed 22 months ago by Reinmar

  • Resolution set to wontfix
  • Status changed from confirmed to closed

comment:6 Changed 22 months ago by j.swiderski

I have tried to reproduce it in IE8-10 and editor 4.x and CKE 3.6.6 but wasn't able seems id is kept there.

This may be because behaviour for backspace was changed. Now cursor is put in last list item and now in new paragraph.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy