Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#8455 closed Bug (worksforme)

mousedown focus is too agressive

Reported by: fbingha Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: General Version: 3.3
Keywords: Cc:

Description (last modified by fredck)

  1. Open the CKEditor demo.
  2. Resize the editor so that it is several pages long, forcing one to scroll the browser several pages to get the bottom of the editor.
  3. Empty the editor contents (Select All then Delete).
  4. Scroll the editor so that the top of the editor is in view.
  5. Click about an inch below the flashing cursor.
  6. Observe that the editor scrolls to the bottom when it should not have scrolled at all.

Change History (7)

comment:1 Changed 5 years ago by fbingha

Duplicating this state in other browsers goes as follows:

FF,IE9: The top of the editor scrolls to the top of the browser. Webkit: No scroll

comment:2 Changed 5 years ago by j.swiderski

  • Status changed from new to confirmed
  • Summary changed from mousedown focus in Opera is too agressive to mousedown focus is too agressive
  • Version set to 3.3

Issue can be reproduced in any CKEditor sample. Deleting content is not necessary.

Results:
Opera scroll to the bottom of the editor.
IE8, IE9 and Firefox "scroll to the cursor" - line with cursor blinking in it is the first in browser viewport.

All issues have been reproducible from CKEditor 3.3.

comment:3 Changed 5 years ago by j.swiderski

I did a quick test and it seems that patch from #7932 has fixed this issue.

comment:4 Changed 5 years ago by j.swiderski

#8688 was marked as duplicate.

comment:5 Changed 5 years ago by fredck

  • Description modified (diff)

comment:6 Changed 5 years ago by fredck

  • Resolution set to worksforme
  • Status changed from confirmed to closed

I'm not able to reproduce this one any more as well.

comment:7 Changed 4 years ago by wwalc

  • Milestone set to CKEditor 3.6.3
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy