Ticket #8553 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

SCAYT Causing Format Errors

Reported by: yeezer1 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc: SpellChecker.net

Description

SCAYT started causing formatting errors this morning. We have bulleted lists in our ckeditor fields, and when SCAYT is enabled, it breaks up the bullets into 1-2 words each. This happens on http://ckeditor.com/demo also. It was happening with version 3.5.3. I upgraded to 3.6.2, but the problem still occurs, so I believe it's only due to some change in the SCAYT component. Here's an example of HTML to use inside the ckeditor field:

<p>
	<strong>Manufacturer&#39;s Description:</strong></p>
<p>
	<strong>Designed To Work With The Following Winches:</strong></p>
<ul>
	<li>
		KFI: S2000 / A2500 / A3000</li>
	<li>
		Warn: U2500 / A2000 / A2500 / 1.5ci / 2.5ci / 2.5ce / 2.5s / 3.0ci / 3.0ce / 3.0s</li>
	<li>
		Warn: RT15 / RT25 / RT30 / XT15 / XT25 / XT30</li>
	<li>
		Ramsey: ATV2500 / ATV3000</li>
	<li>
		Super Winch: All ATV</li>
	<li>
		Marker: All ATV Winches</li>
	<li>
		Venom: All ATV Winches (except the Venom 3500/4000/4500 Hardcore Series)</li>
	<li>
		Champion: C10013 / C10014 / C10018</li>
	<li>
		Champion: C20049 / C20049-2 / C20051 / C20249 / C30045 / C30145</li>
	<li>
		Many Others Similar To The Above (call for details)<br />
		- Standard ATV Winch 4-hole bolt pattern of 3.00&quot; X 4.875&quot;<br />
		- Standard ATV Winch 2-hole bolt pattern of 3.100&quot;<br />
		- Standard ATV Fairlead bolt pattern of 4.875&quot;</li>
</ul>
<p>
	<strong>Specifications:</strong></p>
<ul>
	<li>
		100% Made In USA</li>
	<li>
		Constructed of 3/16&quot; steel</li>
	<li>
		Unlike all other mount competitors our mounts are metal bead blasted before they are powder coated for the best possible finish prep.</li>
	<li>
		Powder coated black for supreme durability</li>
	<li>
		Does NOT work with Polaris OEM Brush Guard or Double Tube Bumper</li>
	<li>
		Works with the new OEM Deluxe Brushguard #2874785-067</li>
	<li>
		Complete installation instructions included</li>
	<li>
		All mounting hardware included</li>
	<li>
		Satisfaction Guaranteed</li>
	<li>
		Roller fairlead and winch not included</li>
</ul>

Attachments

Good.PNG (41.5 KB) - added by yeezer1 3 years ago.
How it should look - on ckeditor.com/demo
Bad.PNG (38.6 KB) - added by yeezer1 3 years ago.
How it changes when SCAYT is turned on - on ckeditor.com/demo

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Cc SpellChecker.net added
  • Keywords SCAYT removed

#8564 was marked as DUP.

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

I which browser, which Operating System does the issue occur and how can those formatting errors be observed (what should I look at)?

comment:3 Changed 3 years ago by j.swiderski

SCAYT has released lately version 2.7 build 1431.

I see that the latest current version is Version 2.7.0 build (1432). Does the issue occur there also?

Changed 3 years ago by yeezer1

How it should look - on ckeditor.com/demo

Changed 3 years ago by yeezer1

How it changes when SCAYT is turned on - on ckeditor.com/demo

comment:4 Changed 3 years ago by yeezer1

I was seeing it on all browsers that I tried. Now, it only seems to happen on Firefox 8, 64-bit Windows 7. I don't know how to change the SCAYT version in CKEditor. I see the problem on your demo page which is using 2.6.4, and I'm seeing the problem on my site which is using 2.7.0 (1431). I have added attachments showing how it should look and how it looks after enabling scayt in FF 8.

comment:5 Changed 3 years ago by j.swiderski

I can see only this good result.

Perhaps if you cleared FF8 cache and pressed CRTL+F5 couple of times this might help to refresh the version?

comment:6 Changed 3 years ago by SpellChecker.net

WebSpellChecker.net confirms that the problem was in W3C browser, not IE in SCAYT core version 2.7 build 1431. The problem was resolved in version 2.7.0 build (1432).

To switch to the latest version of SCAYT core please clear your browser cache where the problem reproduces.

The problem was also reported and commented on CKSource forum: http://cksource.com/forums/viewtopic.php?t=24077

comment:7 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy