Ticket #8598 (closed Bug: worksforme)

Opened 2 years ago

Last modified 2 years ago

Cyrillic characters in CKEditor for ASP.net becomes garbage in ISO-8859-1

Reported by: ElChe Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: 3.6.2
Keywords: encoding, cyrillic Cc:

Description

When using CKEditor for ASP.net 3.6.2 and inputing cyrillic characters, the CKEditorControl.Text property becomes incorrect.

Example insert Text Э into the CKEditor, do a postback. In the postbody, note that it's been correctly converted by the browser to Э since the page is running with charset ISO-8859-1. In CKEditorControl.Text it becomes the character "-".

Workaround for us, it to wrap the control, and have our own IPostBackDataHandler with LoadPostData method where we just assign the wrapped CKEditorControl.Text property to postCollection[postDataKey].

Change History

comment:1 Changed 2 years ago by kaga

I cannot reproduce. Could I ask for a sample .aspx page

comment:2 Changed 2 years ago by ElChe

Did you put <globalization requestEncoding="iso-8859-1" responseEncoding="iso-8859-1" /> in your web.config?

We do nothing special in the aspx.

comment:3 Changed 2 years ago by kaga

  • Status changed from new to closed
  • Resolution set to worksforme

This symbols isn't support in encoding "iso-8859-1" http://www.w3schools.com/tags/ref_entities.asp. Server change Э to another symbols even on sample page without CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy