Ticket #8644 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Issue in Dialog plugin - declaring i as global variable wrongly

Reported by: benny Owned by:
Priority: Normal Milestone: CKEditor 3.6.3
Component: UI : Dialogs Version: 3.6.2
Keywords: Cc:

Description

The file ckeditor/_source/plugins/dialog/plugin.js, line 228 where a single letter variable “i” is used without “var” thereby making it appear under the global scope. That causes problem in the minified ckeditor.js because "i" is referred as CKEDITOR.config when init the instance. After method to removing the cached tabs of dialog is called, the new editor instance can not be created because the "i" is a int value instead of CKEDITOR.config object.

The steps to reproduce:

  1. Create a editor instacne.
  2. Open one dialog plugin like images, link or table and close.
  3. Create another editor instance in the same page
  4. It fails to create another editor instance with js error 'z is undefined or not an object' in ckeditor.js

Change History

comment:1 Changed 3 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to CKEditor 3.6.3

Thanks for the report, I've fixed with with microchange [7351].

Just a note with regards to the reproduction steps (they might be obvious but anyway):

  1. Use the release version, ckeditor_source works fine
  2. In your config.js set something like config.removeDialogTabs = 'flash:advanced'; so the block of code is executed.
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy