Ticket #8685 (closed Bug: wontfix)

Opened 3 years ago

Last modified 2 years ago

Trouble selecting text around tables

Reported by: bradbyu Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: Cc:

Description

Tested in Chrome.

When making a text selection with your mouse in CK Editor, you often have to do it two or more times. Sometimes the selection will reset, sometimes it will change on you, sometimes it will go back to a previous selection. When applying a change to a selection, (deleting the text, appling a style, etc.) the change will often be ignored and the selection/cursor will reset to the start or end of the selected area.

Seems to only happen when in a table where there is content in an adjacent table cell.

This problem was reproduced in the CK Editor Demo and CK Editor 3.6.2 on Dec. 17, 2011.

Attachments

chrome.png (55.4 KB) - added by j.swiderski 2 years ago.

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to wontfix
  1. About Selection.

If you are getting the same result as in shown in screen than the issue is a won't fix this is how Browser handles it. There is nothing CKEditor can do here.
The whole problem is that table is aligned to the right.

If you switch to source you will see:

First Paragraph - "Little Red Riding Hood" is a fa"
Table
Second Paragraph - "The version most widely known t"

But in WYSIWYG you get the impression that the order is:

First Paragraph - "Little Red Riding Hood" is a fa"
Second Paragraph - "The version most widely known t"
Table

When you start selecting Second Paragraph - "The version most widely known t" and then move to table the selection jumps up. This is because this table is in fact above this paragraph and not under it. This is how browser sees it and how it reacts.

This can be tested on a simple HTML page without any CKEditor logic. Result will be the same.


  1. About cursor problems.

What you have described sounds exactly like ticket #8617. Could yu check if this is what you are getting? If not please provide setup by step scenario showing how to reproduce the bug.

@bradbyu I'm closing the issue for now as a Won’t fix. If you are able to provide a reduced test case that is different to #8617 problem, I will reopen this issue.

Changed 2 years ago by j.swiderski

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy