Ticket #8742 (closed Bug: duplicate)

Opened 3 years ago

Last modified 2 years ago

Javascript error when creating table/smiley/form with entermode:ENTER_BR

Reported by: computerpunk Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.0
Keywords: IE Cc:

Description (last modified by Anna) (diff)

I encountered a javascript error when I try to create a table (with default parameters) with the latest ckeditor 3.6.2 samples\ajax.html using Internet Explorer 8. The only thing set in the configuration is entermode (which is set to ENTER_BR).

The javascript error is : nodeValue.length is null or not an object line: 130 char: 973

Steps to replicate the problem

  1. Enter the word "TESTING" without the quotes into CKEditor.
  2. Place cursor before T and press the Enter key. (The word TESTING will be on the 2nd line with a blank line on top).
  3. Place the cursor on the blank line on top of the word Testing.
  4. Click on the table button. The table dialog will appear.
  5. Click on the OK button on the table dialog.

Notice that a table is created but the javascript error mentioned above is shown also.

NOTE: This problem do not seem to happen when I try other entermode e.g. ENTER_DIV or ENTER_P

Can anyone advise on what could be the problem here? Thank you.

Change History

comment:1 Changed 3 years ago by Anna

  • Keywords javascript error,table, entermode,ENTER_BR removed
  • Description modified (diff)

comment:2 Changed 3 years ago by j.swiderski

  • Keywords IE added
  • Status changed from new to confirmed
  • Version changed from 3.6.2 to 3.0
  • Summary changed from Javascript error when creating table with entermode:ENTER_BR to Javascript error when creating table/smiley/form with entermode:ENTER_BR

The same thing happens with forms and smiley’s

Reproducible in IE 6-8 from CKEditor 3.0

Error:
Message: 'nodeValue.length' is empty or not an object
Line: 802
URI: /3.6.2/ckeditor/_source/plugins/selection/plugin.js


In IE9 table/smiley/form is inserted always under br tag and not above it like in other browsers I have reported it here: #8743

comment:3 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

This is actually a duplicate of #8467

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy