Ticket #8810 (closed Bug: wontfix)

Opened 3 years ago

Last modified 3 years ago

lost selection in ie9 when open floatpanel

Reported by: yiminghe Owned by:
Priority: Normal Milestone:
Component: UI : Floating Panel Version: 3.6.2
Keywords: Cc:

Description

steps:

  1. open ckeditor in ie9 mode
  1. select some text as pic1
  1. open font-style floatpanel

expected:

last text selection remains

actual result:

lost last text selection

Attachments

2012-3-16 14-58-08.png (9.5 KB) - added by yiminghe 3 years ago.
pic1
2012-3-16 15-00-55.png (19.7 KB) - added by yiminghe 3 years ago.
pic2

Change History

Changed 3 years ago by yiminghe

pic1

Changed 3 years ago by yiminghe

pic2

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Keywords selection ie9 floatpanel removed
  • Resolution set to wontfix

This is IE and not CKEditor problem.

Please note that although visual selection is gone (it is moved to dropdown) it is still possible to apply style to it.

To get back to selection without loosing it you can use escape key. If you click somewhere else in content area to close the dropdown it's quite normal that selection will be lost (not only the visual one)

comment:2 Changed 3 years ago by yiminghe

@ j.swiderski

I think ckeditor can work around this bug in ie, because ckeditor is so perfect on all platform.

The problem is probably caused by iframed floatpanel, this is why tinymce (which does not use iframe for float panel) is ok in ie9 mode.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy