Ticket #8873 (closed Bug: worksforme)

Opened 2 years ago

Last modified 2 years ago

Safari on Mac: cannot type in the editor after using tab to navigate into the content area

Reported by: tmonahan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM Mac Safari Cc: damo, satya, hokamoto@…

Description

Steps to Reproduce:

  1. Open the api.html sample in Safari on Mac.
  2. Press the Tab key once. This puts focus on CKEditor - a blue rectangle shows focus is on CKEditor, and the caret appears at the top of the content area.
  3. Type some characters.

Issue: No characters can be added in the content area of CKEditor. If you type Shift+Tab, it is then possible to type in the content area.

We have reproduced this on Safari 5.0.6 on Mac OS 10.5.8 and Safari 5.0.3 on Mac OS 10.6.6

Change History

comment:1 Changed 2 years ago by j.swiderski

  • Keywords Mac Safari added
  • Status changed from new to confirmed
  • Version changed from 3.6.3 (SVN - trunk) to 3.0

This is true for Safari 5.0.x only and has been reproducible form CKEditor 3.0.

IMO this is low priority as this is just an issue for MAC Leopard only. Both SNOW LEOPARD 10.6.8 (can be updated from 10.6.3) and LION 10.7.3 can now use safari 5.1.5 which does not have this problem (In fact not even Safari 5.1 has it).

comment:2 Changed 2 years ago by garry.yao

WFM with Safari 5.1.x on OSX 10.7.

comment:3 Changed 2 years ago by fredck

  • Status changed from confirmed to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy