Opened 5 years ago

Closed 4 years ago

#8925 closed Bug (fixed)

FF: Window scrolls to top when closing the table properties dialog

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.4
Component: General Version: 3.3
Keywords: Firefox IBM Cc: satya, tmonahan

Description

To reproduce:

  1. Create a table that is large enough to cause the editor scroll bar to appear.
  1. Edit the table by right-clicking inside the last row of the table
  1. Set the table alignment to left or right
  1. Click OK

Expected: Focus returns to the cell that was clicked into, the view remains in the same place on the document.

Actual: The cursor appears to remain in the cell, but the window scrolls to the top of the document.

The scrolling problem manifests itself whenever the dialog is discarded (either OK or Cancel button) and the alignment on the table is set to left or right.

Attachments (3)

8925.patch (1.2 KB) - added by garry.yao 4 years ago.
8925_2.patch (2.0 KB) - added by garry.yao 4 years ago.
8925_3.patch (750 bytes) - added by garry.yao 4 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by tmonahan

This issue also occurs when the context menu is opened and closed on a table which has align set to left or right. The table must contain enough rows to make it larger than the editing viewpane.

comment:2 Changed 5 years ago by j.swiderski

  • Keywords Firefox added
  • Status changed from new to confirmed
  • Version set to 3.3

Clicking on already aligned table (it can't have focus) has caused editor to scroll up from CKEditor 3.3

Aligning table (from alignment set to none) like described in ticket has caused editor to scroll up from CKEditor 3.3.1

Reproducible only in Firefox.

Changed 4 years ago by garry.yao

comment:3 Changed 4 years ago by garry.yao

  • Milestone set to CKEditor 3.6.4
  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:4 Changed 4 years ago by garry.yao

  • Status changed from review to assigned

Unfortunately that patch doesn't work once the element is modified, so it looks like it's an side effect brought by the focus call which cannot be worked around.

comment:6 Changed 4 years ago by garry.yao

  • Status changed from assigned to review

Propose to remove the "blink cursor" hack from #5622, which is outdated, is the root of this problem.

Changed 4 years ago by garry.yao

comment:7 Changed 4 years ago by fredck

  • Status changed from review to review_failed

Well... that outdated hack is still valid for an outdated browser we still support: Firefox 3.6.

As we're dealing with something hard to fix and with browser bugs, we can at least reduce the incidence of this issue. So, instead of removing blinkCursor alltogether, what about enabling it just when CKEDITOR.env.version == 10902?

Changed 4 years ago by garry.yao

comment:8 Changed 4 years ago by garry.yao

  • Status changed from review_failed to review

Limited the fix to only FF3.x.

comment:9 Changed 4 years ago by fredck

  • Status changed from review to review_passed

comment:10 Changed 4 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7517].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy