Opened 3 years ago

Closed 3 years ago

Last modified 19 months ago

#8968 closed Bug (fixed)

FF: Pasting content (CRTL+V) from MS Word 2010 with forcePasteAsPlainText turned on pastes MS junk

Reported by: j.swiderski Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.4
Component: Core : Pasting Version: 3.6.3
Keywords: Firefox Cc:

Description

To reproduce:

  1. In your config.js set config.forcePasteAsPlainText = true;
  2. Open any MS Word 2010 document and copy formatted text with CRTL+C
  3. Paste contents in to editor using CRTL+V (Toolbar buttons work fine)

Result: MS junk code is pasted into editor.

Issue has been reproducible in Firefox from CKEditor 3.6.3.

The first change - all pasted in one paragraph can be seen from rev [7453] but there is no MS junk. In next revision [7454] junk is present.

Attachments (1)

8968.patch (762 bytes) - added by garry.yao 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

Changed 3 years ago by garry.yao

comment:2 Changed 3 years ago by garry.yao

  • Milestone set to CKEditor 3.6.4
  • Owner set to garry.yao
  • Status changed from confirmed to review

There exists a limitation in Fx to have our "text pastebin" work on the "paste" event (where we've used to rely on "beforepaste" before [7453]).

The patch is enought to fix the Ctrl-V behavior, but not when pasting from menu bar, unfortunately, while it should be enough at the moment, since it has been addressed already in v4, where we introduced no special "text pastebin" at all.

comment:3 Changed 3 years ago by fredck

  • Status changed from review to review_passed

comment:4 Changed 3 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7534].

comment:5 Changed 19 months ago by fredck

  • Component changed from General to Core : Pasting
Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy