Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#90 closed Bug (fixed)

Disappearing <br /> in non-empty list item

Reported by: kwillems Owned by:
Priority: Normal Milestone: FCKeditor 2.4.1
Component: UI : Enter Key Version: FCKeditor 2.4
Keywords: IE, Confirmed Cc:

Description (last modified by fredck)

I would like to create XHTML as the following:

<ul>
    <li class="decimal">
        <span class="ol">1. </span><em>Test 1</em><br />
        This line should appear on a new line, because a '<br />'
        was entered with 'SHIFT + ENTER, just after '<em>Test 1</em>'.
    </li> 
</ul>

But in fact in (Internet Explorer 7) when I hit SHIFT + ENTER a single time, the <br /> diasappears (for example: after switching to source-mode and back).

In Firefox i've no problem at all and SHIFT + ENTER behaves like expected!

I found two 'solutions':

  1. Remove the <em> and </em> surrounding 'Test 1'
  2. Hit SHIFT + ENTER twice!!!!

For me this is a huge problem, because the users of my CMS (most of them use Internet Explorer) of course would never think about hitting SHIFT + ENTER twice.

Regards,
Koen Willems

Attachments (1)

FCK remove br.avi (132.1 KB) - added by zheng@… 9 years ago.
FCK remove <br /> after any closing tags #168 doesn't work

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by fredck

  • Description modified (diff)
  • Keywords IE added
  • Summary changed from disappearing <br /> in non-empty listitem to Disappearing <br /> in non-empty list item

Confirmed on IE 6 also. Ok with Firefox.

Steps to reproduce:

  1. Enter the following code in the source:
<ul>
    <li class="decimal"><span class="ol">1. </span><em>Test 1</em>This line should appear on a new line, because a '&lt;br /&gt;' was entered with 'SHIFT + ENTER, just after '&lt;em&gt;Test 1&lt;/em&gt;'.</li>
</ul>
  1. Switch back to WYSIWYG.
  1. Place the cursor right after "Test 1".
  1. Hit Shift+Enter. The <br> will be correctly included.
  1. Switch back to source. The <br> will not be there anymore.

comment:2 Changed 9 years ago by fredck

  • Keywords Confirmed added

comment:3 Changed 9 years ago by fredck

#122 is probably a DUP of this one.

comment:4 Changed 9 years ago by fredck

Confirmed #122 and #124 as DUP of this one.

comment:5 follow-up: Changed 9 years ago by fredck

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [168].

Click here for more info about our SVN system.

comment:6 in reply to: ↑ 5 Changed 9 years ago by anonymous

Replying to fredck:

Fixed with [168].

Click here for more info about our SVN system.

Wow! Thanx very much for fixing this one!!!!!

Regards,
Koen Willems

comment:7 Changed 9 years ago by fredck

  • Milestone changed from FCKeditor 2.4 to FCKeditor 2.4.1

Changed 9 years ago by zheng@…

FCK remove <br /> after any closing tags #168 doesn't work

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy