Ticket #9016 (closed Bug: fixed)

Opened 23 months ago

Last modified 22 months ago

IFrame semantics of File input need to be removed

Reported by: damo Owned by:
Priority: Normal Milestone: CKEditor 3.6.4
Component: Accessibility Version: 3.0
Keywords: IBM Cc: satya, tmonahan

Description

When the File upload input is enabled, an IFrame is rendered in the UI. Due to the presence of this IFrame, proper markup would need to be applied to the IFrame's document as for any other full document.

Since this IFrame is not intended to present a full HTML document, but rather is the container for the upload input, its IFrame semantics could be removed.

One way to resolve this is to apply role="presentation" to this IFrame.

Change History

comment:1 Changed 23 months ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.0

Adding role="presentation" sounds harmless IMO.

comment:2 Changed 23 months ago by damo

What is the ETA for a fix to address this issue?

comment:3 Changed 22 months ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed
  • Milestone set to CKEditor 3.6.4

Fixed with [7494].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy