Ticket #9097 (closed Bug: fixed)

Opened 2 years ago

Last modified 23 months ago

Selection at the beginning of paragraphs is broken on IE9 and IE8

Reported by: j.swiderski Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.5
Component: General Version: 3.6.3
Keywords: IE8 IE9 IBM Cc: monahant@…, satya_minnekanti@…

Description (last modified by j.swiderski) (diff)

I have found it when checking #9093

To reproduce:

  1. Insert below code and switch to WYSIWYG
    <p>aaa</p>
    <p>bbb</p>
    <p>ccc</p>
    
  2. Try to select 'bbb' but start your selection a little bit to the left of 'bbb' like shown in picture.
  3. Once bbb is selected press Enter key

Result: new line is inserted above 'aaa'

Alternative step 3:

  1. Once bbb is selected, press Link button and insert a link. Note that the link is inserted in the wrong place (at the end of contents).

The same thing happens with inline styles - they are added at the end of content. You can inspect it only with developer tools.

This issue has only been reproducible in IE8 and IE9 from CKEditor 3.6.3

Attachments

ie89.png (12.2 KB) - added by j.swiderski 2 years ago.
9097.patch (3.3 KB) - added by garry.yao 2 years ago.
9097_2.patch (6.8 KB) - added by garry.yao 2 years ago.

Change History

Changed 2 years ago by j.swiderski

comment:1 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed

Reproducible from rev. [7374]

comment:2 Changed 2 years ago by wwalc

  • Description modified (diff)
  • Summary changed from Enter command is broken on IE9 and IE8 to Selection at the beginning of paragraphs is broken on IE9 and IE8

comment:3 Changed 2 years ago by garry.yao

It's caused by the revert of one of our previous wysiwygarea hack, considering that [7374] cannot coexist with it, we'd rather leave this one right now, which is relatively an small case.

comment:4 Changed 2 years ago by tmonahan

  • Cc monahant@… added
  • Keywords IBM added

comment:5 Changed 2 years ago by satya

  • Cc satya_minnekanti@… added

adding myself to cc

comment:6 Changed 2 years ago by j.swiderski

  • Description modified (diff)

#8961 is a duplicate of this one.

Last edited 2 years ago by j.swiderski (previous) (diff)

comment:7 Changed 2 years ago by j.swiderski

Next to #9175 this is another issue caused by this revision.

Please also note that fix presented in [7374] is not complete - please see #8919

comment:8 Changed 2 years ago by tmonahan

Ticket #8964 was also closed as a duplicate of this one.

Changed 2 years ago by garry.yao

comment:9 Changed 2 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review
  • Milestone set to CKEditor 3.6.5

The patch unifies the behavior in all IEs, to allow selection start from all body margins.

comment:10 Changed 2 years ago by fredck

  • Status changed from review to review_failed

With IE8 at least:

  • Create 3 lines of text.
  • Start dragging from the bottom-right whitespace part of the editor to make a selection up to the top-left.

It will work well for the first line only. As soon as the above lines get reached, the selection gets lost and we have a strange behaviour.

I didn't test it with other IE versions.

Changed 2 years ago by garry.yao

comment:11 Changed 2 years ago by garry.yao

  • Status changed from review_failed to review

New patch addressed the above described issue, in IE > 8, the patch also has some indentation changes, that would be ignored when comparing a diff.

comment:12 Changed 23 months ago by fredck

  • Status changed from review to review_passed

comment:13 Changed 23 months ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7600].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy