Opened 4 years ago

Closed 4 years ago

#9281 closed Bug (fixed)

Safari: Error on table dialog when border:none is added to the styles field

Reported by: tmonahan Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.5
Component: General Version: 3.0
Keywords: IBM Cc: damo, satya

Description

To Reproduce:

  • Open any sample in Safari and insert a table.
  • Open the Advanced tab on the table dialog, specify the following in the styles field and click OK:
    width: 500px; border:none;
    
  • Open the Table Properties dialog again and click Ok.

Problem: The error dialog displays saying that the syntax of the styles field is incorrect.

If you look at the value of the styles field it now has the following value:

border-top-style: none; border-right-style: none; border-bottom-style: none; border-left-style: none; border- border-color: initial; width: 500px;width: initial

The border- before border-color: initial; causes the error to appear.

This error only occurs if the width styling is also applied.

This can also be reproduced easily when pasting a standard table from Word that has a width set with the following configuration options:

config.pasteFromWordRemoveFontStyles = false;
config.pasteFromWordRemoveStyles = false;

Attachments (1)

9281.patch (4.3 KB) - added by garry.yao 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by garry.yao

comment:1 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from new to review

It's caused by an incomplete impl of the dialogadvtab plugin's updateStyle function, which incorrectly removed 'border-width' when removing the style "width", propose to switch to DOM-based computation, to properly handle complex case, e.g. CSS property components.

Opened ticket test: http://ckeditor.t/dt/plugins/dialogadvtab/1.html

Last edited 4 years ago by fredck (previous) (diff)

comment:2 Changed 4 years ago by garry.yao

  • Milestone set to CKEditor 3.6.5
  • Version changed from 3.6.5 (SVN - trunk) to 3.0

comment:3 Changed 4 years ago by fredck

  • Status changed from review to review_passed

comment:4 Changed 4 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7622].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy