Ticket #986 (closed Bug: expired)

Opened 7 years ago

Last modified 5 years ago

Window not stopped

Reported by: Eric Brison Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: WorksForMe Cc:

Description

In Linux (also on windows XP) / Firefox 2.0.0-5 - FCK editor 2.5 SVN No problem with Internet Explorer.

When I have 2 editors : one visible and the other unvisible, the window loading not stop and other onload event functions are not launch until window.stop() is called.

If the 2 are visbles : it's OK

If the 2 are unvisible : it's OK also.

See example to view the problem.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
        <title>FCKeditor - Sample</title>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
        <meta name="robots" content="noindex, nofollow" />
        <script type="text/javascript" src="/usr/share/what/fckeditor/fckeditor.js"></script>
</head>
<body>
        <h1> FCKeditor - JavaScript - Double Editor</h1>
        <div> First is visble, second is hidden   </div>
        <hr />             <br />
<form action="sampleposteddata.asp" method="post" target="_blank">
                
<a onclick="document.getElementById('fsecond').style.display=''">View Second Editor</a>
<fieldset id="ffirst" ><legend>First</legend>
<script type="text/javascript">
var sBasePath = '/usr/share/what/fckeditor/' ;
var oFCKeditor = new FCKeditor( 'FCKeditor1' ) ;
oFCKeditor.BasePath     = sBasePath ;
oFCKeditor.Value        = 'First Editor' ;
oFCKeditor.Create() ;
</script>
                <br />
</fieldset>

<fieldset id="fsecond"  style="display:none"><legend>Second</legend>
<script type="text/javascript">


var oFCKeditor2 = new FCKeditor( 'FCKeditor2' ) ;
oFCKeditor2.BasePath     = sBasePath ;
oFCKeditor2.Value        = 'Second editor' ;
oFCKeditor2.Create() ;

                </script>
                <br /></fieldset>
                <input type="submit" />
        </form>
</body>
</html>

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by w.olchawa

  • Keywords Pending WorksForMe added
  • Version set to FCKeditor 2.5

Hi!

I tried to reproduce your bug using the latest SVN and the stable version 2.5.1 and I was unsuccessful.

Everything works fine for me but to be certain please check if the bug still occurs using 2.5.1. If not we will immediately close this ticket.

Thanks

comment:2 in reply to: ↑ 1 Changed 6 years ago by Eric Brison

Replying to w.olchawa:

I redo the test with FCKeditor 2.5.1 (Build 17566). I'm on linux with firefox 2.0.0.12. The first try, the test works. But when I reload the page, I have this problem. Could be a problem when script is already an the navigator cache. But Javascript Error console is empty (no error detected). Only the cursor and the waiting symbol are displayed. To see the effect you can add "<body onload="alert('Good')>" on the body tag. For me, the alert is done only when I push the stop button of the navigator.

I redo the test also on Window's XP with firefox 2.0.0.12, it work fine now. The problem is now only on linux system.

Thank you.

Eric.

comment:3 Changed 6 years ago by fredck

  • Keywords Pending removed

comment:4 Changed 5 years ago by arczi

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy