Changes between Initial Version and Version 1 of Ticket #10536


Ignore:
Timestamp:
Jun 12, 2013, 12:01:52 PM (7 years ago)
Author:
Piotrek Koszuliński
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #10536

    • Property Status changed from new to confirmed
  • Ticket #10536 – Description

    initial v1  
    442. `htmlParser.fragment.fromHtml` -> `htmlParser.parse` - this method creates fragments, but also elements (depending on arguments).
    553. `editable.attachListener`
    6  * Firstly, it's name isn't clear and I don't see a chance to make it clear. Therefore I'd rename it to `editable.on2`. Similarly to bookmarks and bookmarks2.
     6 * Firstly, its name isn't clear and I don't see a chance to make it clear. Therefore I'd rename it to equally unclear `editable.on2`. Similarly to `bookmarks` and `bookmarks2`.
    77 * Secondly, it is always used with `contentDom` event. Therefore we can introduce `editor.on2` being a combination of both. This should simplify our code, but also would make it simpler to explain that to others. This method would executed listener immediately if editor already has initialized editable and would always register `contentDom` listener that adds this event again.
    8 4. We can change some `get*` to their simpler versions (`*`). E.g.: `getParent, getFirst, getLast, getPrevious, getNext, getName, getChild, getSelection, getDocument, getRanges`, etc. It's for making code easier to write. It won't save a significant number of kbytes (I've made a static analysis and saved ~1% in gzipped package after making even more changes).
     84. We can change some `get*` and `set*` methods to their simpler versions (`*`). E.g.: `getParent, getFirst, getLast, getPrevious, getNext, getName, getChild, getSelection, getDocument, getRanges, getAttributes, setAttributes`, etc. It's for making code easier to write and shorter (in terms of lines length). It won't save a significant number of kbytes (I've made a static analysis and saved ~1% in gzipped package after making even more changes).
    995. `Editor#instanceReady` to `#ready` (#9911).
    10106. `listener#removeListener` to `#remove`.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy