Opened 6 years ago

Closed 6 years ago

#10868 closed Bug (fixed)

IE8: Page crashes when Inline Quotation is used.

Reported by: Jakub Ś Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.2.2
Component: General Version: 4.0
Keywords: IE8 Cc:

Description

  1. Open replacebycode sample and clear page with New Page command or with Ctrl+A Del
  2. Go to styles dropdown and select Inline Quotation.
  3. If page hasn't crashed yet then please press Enter key. Page will crash and UIE will reload it.

I was able to reproduce this problem in IE8 only from CKEditor 4.0

Change History (9)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Summary: IE8: crashes when Inline Quotation is used.IE8: Page crashes when Inline Quotation is used.

comment:2 Changed 6 years ago by Olek Nowodziński

cc

comment:3 Changed 6 years ago by Marek Lewandowski

good news - i can no longer reproduce this bug in current version - so it should be solved with 4.3 beta :)

Version 0, edited 6 years ago by Marek Lewandowski (next)

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

comment:5 Changed 6 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:6 Changed 6 years ago by Piotrek Koszuliński

First bad commit is git:c8b8caad59. It took me half an hour to find this because IE is crashing very badly.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/10868 with a solution which seems to work. IE8 is crashing when there's an img:hover style, so I made it invalid for IE8, which does not understand :not() selector.

http://caniuse.com/css-sel3

comment:8 Changed 6 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

I curious to hear how you figured this out :D

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed with git:2c044fd on master.

I curious to hear how you figured this out :D

First I did a painful binary lookup in history and then when I found out that this were changes in contents.css what started the problem I tried to find which rules exactly and... it was img:hover :D

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy