Opened 7 years ago

Last modified 7 years ago

#14919 pending Bug

hitting enter in a ckeditor when multiple ckeditors are on the page, scrolls randomly down the page in IE 11 only

Reported by: Christa Fitzpatrick Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:


Steps to reproduce

  1. Open a page in IE11 that has about 5 ckeditors on a single page.
  2. scroll down the page to a ckeditor that you can not see unless you scroll.
  3. put the cursor in that ckeditor and type a word and then hit enter.
  4. The cursor stays in the ckeditor but the webpage randomly scrolls downward and you have to scroll back up to find where your cursor is.

This does not happen in Firefox, Chrome or MS Edge. The check editor doesn't scroll when enter is pushed in those browsers. In the config.js I have the doctype set to html 4 and it does not help per issue I am using ckeditor 4.5.11. This is happening only in IE 11 in Windows 10 and Windows 7.

Attachments (1)

14919.html (699 bytes) - added by Tade0 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Tade0

Attachment: 14919.html added

comment:1 Changed 7 years ago by Tade0

Status: newpending

Works for me in IE11 in Win10. Attached document used to attempt reproducing. Does it reproduce using this file?

Version 1, edited 7 years ago by Tade0 (previous) (next) (diff)

comment:2 Changed 7 years ago by Christa Fitzpatrick

I tested with the file and when there are 5 textareas then it works, however when I add 8 textareas and type something and hit enter in the 5th and 6th textareas, the page scrolls down and you can't see these text areas. You have to manually scroll back up the page to see the one that has the cursor. The cursor is in the correct textarea, but can't see it until you scroll back up.

comment:3 Changed 7 years ago by Jakub Ś

Keywords: randomly scrolls IE 11 pressing enter key removed
Version: 4.5.11

I haven't been able to reproduce it as well with attached sample (extended to 10 editors). @cfitzpatrick have you perhaps got some non-standard settings in your IE11 or these are default settings?

So far 3 people have tried one HTML file and two of them can't recreate the issue. @cfitzpatrick If you haven't attached any third-party scripts to that file then the only thing which comes to my mind is some non-standard setting in your IE11.

Last edited 7 years ago by Jakub Ś (previous) (diff)

comment:4 Changed 7 years ago by Christa Fitzpatrick

I do use bootstrap version 3.2.0. Above you say 2 out of 3 CAN recreate the issue, or is that a typo? My IE11 has standard settings, I set it back to default settings just to verify.

comment:5 Changed 7 years ago by Jakub Ś

Above you say 2 out of 3 CAN recreate the issue, or is that a typo?

This was a typo - I have corrected it.

I do use bootstrap version 3.2.0.

This may be a very important detail which you should have mentioned in the first place. First of all, please tell me if you can recreate the problem with attached HTML file (you can extend it to 8 or more editors) and not changed sample file (it means you don't add any extra libraries to it)? If not, please provide a working sample HTML file which I could use inside default CKEditor and see the problem (you can create something like ckeditor/samples/old/replacebycode.html).

comment:6 Changed 7 years ago by Christa Fitzpatrick

After trying it without any 3rd party scripts, it worked fine and worked fine with bootstrap only. After trial and error of taking away 3rd party scripts I discovered that it is a glyphicon script that is causing this issue. So the ckeditor and one of the glyphicon files probably have the same property name or something the same name and are either being combined when called or one is overriding the other. I have not figured out the exact property or glyphicon file yet. But can let you know when we do. I use the following ckeditor plugins - justify, scayt, and the office 2013 skin.

comment:7 Changed 7 years ago by Jakub Ś

But can let you know when we do.

Please do so. We are interested in learning what the conflicting property is exactly. Especially when it would turned out this is editor fault.

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy