Ticket #1062 (closed New Feature: fixed)

Opened 7 years ago

Last modified 20 months ago

On the fly changes to shared toolbar based on different configurations

Reported by: dinu Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: FCKeditor 2.4.3
Keywords: Discussion Cc:

Description

Using fckeditor with BodyClass='cpage'; define in main html: .cpage h1 { ...any-style-here... } when editor loads, all the format preview tabs are blank (white/white text) except where specifically defined in css with color:black

Attachments

fckbug.html (954 bytes) - added by dinu 7 years ago.
fckbug.css (57 bytes) - added by dinu 7 years ago.
fckbug2.html (944 bytes) - added by dinu 7 years ago.
fckbug2.css (66 bytes) - added by dinu 7 years ago.

Change History

comment:1 Changed 7 years ago by alfonsoml

  • Status changed from new to closed
  • Keywords css format removed
  • Resolution set to invalid

The format dropdowns will use the stylesheet that you have provided.

If you fail to set properly the combination of background-color and color then of course it will be displayed wrong, but you should be sure to always specify both settings or make sure that they don't interfere with each other.

comment:2 Changed 7 years ago by dinu

  • Status changed from closed to reopened
  • Resolution invalid deleted

Ok, I wasn't too clear, let me datail: when I define a style for h1 such as: .cpage h1 { text-size: 20px } or even: .cpage h1 {} then ALL the format dropdown tabs go white/white: p, div, pre, h1-h6. This always happens in Mozilla; in IE, seems that sometimes it gets it right (about 1 in 10 refreshes).

comment:3 Changed 7 years ago by alfonsoml

  • Keywords Pending added

That must be a problem with your stylesheet. Please attach it here (or just search in it for the places where you have set color:#FFFFFF)

comment:4 Changed 7 years ago by dinu

Ok, I pinned it down. The problem seems to be when using 2 or more editors using the same toolbar location; in this case, the style and format preview tabs don't get updated when switching from one edit area to the other. I'm attaching the html and css to reproduce the problem. Note that:

1) In the format dropdown the <h1> block is always red, even tho in the second edit area it's actually blue

2) In IE7, the toolbar doesn't get sized properly with the current setup (this should be another bug)

Changed 7 years ago by dinu

Changed 7 years ago by dinu

comment:5 Changed 7 years ago by dinu

On more thinking, it seems that the styles also get mixed between the different areas, because my white/white boxes were a result of white background in the first box and white text in the second.

comment:6 Changed 7 years ago by dinu

Adding fckbug2 files to show the white/white bug and how styles get mixed between the boxes.

Changed 7 years ago by dinu

Changed 7 years ago by dinu

comment:7 Changed 7 years ago by alfonsoml

  • Keywords Discussion added; Pending removed
  • Component changed from Core : Styles to UI : Toolbar

I don't think that the shared toolbar is supposed to work if the different instances of the editor are using different configuration settings.

That would mean that the elements like the dropdowns have to be recreated to adjust for each instance as soon as the focus moves from one area to the other, or keep those items hidden for each area and readjust.

Anyway, lots of work. It would be much easier to have one toolbar for each editing area and then hide/show them as necessary.

comment:8 Changed 7 years ago by dinu

Yea, but it's already slow as it is; if I add 3 or for editors on the page then it takes forever for the JS to initialize. I think a minimal support for multiple style boxes would be great.

comment:9 Changed 7 years ago by fredck

  • Summary changed from 'Format' list styles get screwed when one gets redefined to On the fly changes to shared toolbar based on different configurations
  • Type changed from Bug to New Feature
  • Milestone set to FCKeditor 3.x

For now, this is a missing feature. For now, the shared toolbar works properly when all sharing instances have the same settings. After all, "sharing" means using the same thing.

It would be quite complicated, and also a performance pain, to have the combos redefined when switching editors. I'm sure that this problem would get extended to other things too, like different colors, different plugins, etc., so this thing could get bigger and bigger.

The only feasible way would be creating different toolbars for each instance, and show/hide them when switching editor. If this situation slows down the loading performance, then it is better for us to work to enhance the loading performance, than creating weird things to specific needs.

We'll be working on the loading performance for version 3.0. Probably we'll be able re-think about it after that.

comment:10 Changed 7 years ago by dinu

I realise that, you're right. Just a quick thought tho: would it be possible to make it so that the editor could reside entirely in a different frame than the edit box; this way we could load the editor in a hidden frame once and then just re-connect to the coresponding edit boxes when navigating in the main frame. I think this would mean a huge speed boost for most applications.

comment:11 Changed 7 years ago by fredck

That's actually the base of the performance improvements for version 3. All editor instances will be controlled by a single runtime environment. Using an <iframe> to hold it is an option we are considering to avoid code contamination. We'll be coming with a deeper analysis for it later. Thanks for your suggestions.

comment:12 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:13 Changed 20 months ago by Reinmar

  • Status changed from reopened to closed
  • Resolution set to fixed

I think that this issue expired. Shared spaces render separate toolbars for each editor instance so nothing is shared (except of space ofc :).

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy