Opened 3 years ago

Closed 2 years ago

#11905 closed Bug (fixed)

editor#resize event should pass dimensions in data

Reported by: a.nowodzinski Owned by: a.delura
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version:
Keywords: Cc:

Description

At the moment, there's no simple way to save editor dimensions (those passed to editor.resize()) when user resizes the editor. It also means that there's no way to restore them, i.e. if user re-visits the page.

Following the question on SO.

Change History (10)

comment:1 Changed 3 years ago by Reinmar

  • Milestone set to CKEditor 4.5.0
  • Status changed from new to confirmed

comment:2 Changed 3 years ago by a.delura

  • Owner set to a.delura
  • Status changed from confirmed to assigned

comment:3 Changed 3 years ago by a.delura

  • Status changed from assigned to review

Changes and tests in branch:t/11905. Also reported #12357.

Use cases:

  • rezise by code.
  • resize by user interface (right bottom handler).
  • maximize plugin.
  • window resize while CKEditor is maximized.
  • collapse / expand toolbar.
Last edited 3 years ago by a.delura (previous) (diff)

comment:4 follow-up: Changed 2 years ago by pjasiun

  • Status changed from review to review_failed

comment:5 in reply to: ↑ 4 Changed 2 years ago by a.delura

Replying to pjasiun:

I commented them because they fails, they are new ones. I reported ticket:12357 for them as well. I don't see nothing wrong here. But instead of adding commented assersions I could also create a ticket branch #12357 and put them there.

comment:6 Changed 2 years ago by a.delura

  • Status changed from review_failed to review

Changes in branch:t/11905.

comment:7 follow-up: Changed 2 years ago by pjasiun

  • Status changed from review to review_failed
  • Finish button in the manual test does not work, because 1.js file does not contain bender.test method. If manual test contains testName.js file it is the automatic part of the test which will be run when manual part of the test is done (this is why manual test with testName.js has Finish button instead of Pass). If you just want to execute some javascript in your tests put it in the HTML file or create _assets folder.
  • do not use localStorage in your test, every test should be independent, use variable instead,
  • move manual test to the resize plugin folder.

comment:8 in reply to: ↑ 7 Changed 2 years ago by a.delura

  • Status changed from review_failed to review

Done everything. Changes and tests in branch:t/11905.

comment:9 Changed 2 years ago by pjasiun

I pushed 2 small changed to tests and majorized branch, git:6cdf588.

comment:10 Changed 2 years ago by pjasiun

  • Resolution set to fixed
  • Status changed from review to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy