Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11917 closed Bug (invalid)

Getting < at the end of the paragraph in outlook

Reported by: sumit Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Sample paragraph below:

Orders issued on or after August must be made to xxx Private Limited.<

The "<" below is the one coming in outlook but not shown in ckeditor.

Attachments (1)

pastebin.html (712 bytes) - added by Reinmar 3 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 years ago by Reinmar

  • Keywords &lt removed
  • Status changed from new to pending

Apparently Outlook produces some crappy HTML which breaks while parsing. We don't support pasting from Outlook, as we do for MSWord, at the moment, but if this is more general problem we can take a look.

However, first we must know on which browser and CKEditor version does it happen. We also need the HTML produced by Outlook. In order to find this out download pastebin.html, open it in a browser, paste copied content in side the green box and the produced HTML will be in the textarea below. Include it in your comment.

Changed 3 years ago by Reinmar

comment:2 Changed 3 years ago by sumit

I am not pasting anything from outlook. Content to Outlook is the end result. I am using CK editor from IE 9.

html from pastebin:

<p><strong>Important Information </strong><br><br>Agilent's Electronic 
Measurement Group is becoming Keysight Technologies!<br><br>Effective August 1, 
2014 all rights and obligations associated with this quotation and any 
subsequent order will be assigned to Keysight Technologies. The terms and 
conditions of the quotation and order will not change.<br><br><strong>Purchase 
Orders issued prior to August 1, 2014 must be made to Agilent 
Technologies.</strong><br><br><strong>Purchase Orders issued on or after August 
1, 2014 must be made to Keysight Technologies India Private 
Limited.</strong></p><p><strong></strong></p>

EndResult on Outlook's html version adding &lt; at the end of para:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><title>Quick Quote Email</title></head><body>	<style type="text/css">    	a  { color:#0085d5; text-decoration:none;}    	a:link {color:#0085d5; text-decoration:none; }    	a:hover { color:#0085d5; text-decoration:underline;}	</style>	<div style="background-color: #FFFFFF; font-family: Arial, Verdana, Helvetica, sans-serif; font-size:13px">				<div style="border-bottom: 4px solid #003972; margin-bottom:1em;">							<img src="http://prdpre.home.agilent.com/agilent/images3/page/agilentlogo-cfd.gif" alt="Agilent Technologies" width="250" height="50" border="0">		</div>						<h1 style="margin-bottom:0; font-size:19px; padding-bottomo:0;">			Your Requested Quick Quote 		</h1>						<table border="0" cellpadding="0" cellspacing="0" width="100%">			<tr valign="top" style="font-family: Arial, Verdana, Helvetica, sans-serif; color:#444444;">				<td>					<table style="border-top-width:12px; border-top-color:#FFFFFF; border-top-style:solid; border-right-width:5px; border-right-color:#FFFFFF; border-right-style:solid;">						<tr valign="top" style="font-family: Arial, Verdana, Helvetica, sans-serif; color:#444444;">							<td>								<p style="font-size:13px;">																																																<strong>Important Information</strong><br><br>Agilent's Electronic Measurement Group is becoming Keysight Technologies!<br><br>Effective August 1, 2014 all rights and obligations associated with this quotation and any subsequent order will be assigned to Keysight Technologies. The terms and conditions of the quotation and order will not change.<br><br><strong>Purchase Orders issued prior to August 1, 2014 must be made to Agilent Technologies.</strong><br><br><strong>Purchase Orders issued on or after August 1, 2014 must be made to Keysight Technologies. Inc.</strong>&lt;																</p>																<h4 style="margin-bottom:0.6em; font-size:13px; color:#444444;">Products in this Instant Quote</h4>								<ul style="padding-top:0; margin-top:0; margin-bottom:1.5em;">																																				<li style="margin-top:0; margin-bottom:0.4em; font-size:13px; padding-top:0;"><a href="http://prdpre.home.agilent.com/en/pd-2342436-pn-N9010A/n9010a-exa-rf-narrowband-36-ghz-25-mhz-bandwidth?cc=US&amp;lc=eng" style="color:#0085d5;">Agilent  N9010A EXA RF Narrowband  – 3.6 GHz, 25 MHz Bandwidth</a></li>																												</ul>																<h4 style="margin-bottom:0.3em; font-size:13px; color:#444444;">Contact Information: Agilent</h4>								<p style="margin-top:0; margin-bottom:1px; font-size:13px;">Please contact us if you need any further assistance or if you have any questions.</p>															<table border="0" cellpadding="3" cellspacing="0">																																					<tr style="font-family: Arial, Verdana, Helvetica, sans-serif; color:#444444;">													<td style="font-size:13px;">toll-free</td>													<td style="font-size:13px;">&#43;1 (800) 829-4444</td>												</tr>																																											<tr style="font-family: Arial, Verdana, Helvetica, sans-serif; color:#444444;">												<td style="font-size:13px;">fax:</td>												<td style="font-size:13px;">&#43;1 (800) 829-4433</td>											</tr>																																																		<tr style="font-family: Arial, Verdana, Helvetica, sans-serif; color:#444444;">													<td style="font-size:13px; padding-bottom:2.2em;">Email:</td>													<td style="font-size:13px; padding-bottom:2.2em;"><a href="mailto:usa_orders@agilent.com" style="color:#0085d5;">usa_orders@agilent.com</a></td>												</tr>																																</table>																<p style="margin-left:3px;margin-top:0em; padding-top:0; font-size:13px; vertical-align:top;"><a href="http://www.adobe.com/go/reader" style="color:#0085d5;"><img src="http://prdpre.home.agilent.com/agilent/images3/page/acroread.gif" width="26" height="20" alt="" style="border:none; vertical-align:middle;">&nbsp;Get Adobe Reader</a></p>									</td>						</tr>					</table>				</td>												</tr>		</table>	</div>			</body></html>
Last edited 3 years ago by Reinmar (previous) (diff)

comment:3 Changed 3 years ago by Reinmar

I am not pasting anything from outlook. Content to Outlook is the end result. I am using CK editor from IE 9.

So I don't understand. What is the test case? What should I do step by step to reproduce this issue?

comment:4 Changed 3 years ago by sumit

Test case to replicate:

Step 1: I added the text below to CKEditor and did not see any extra character after entering and saving in the CKEditor:

Important Information

Agilent's Electronic Measurement Group is becoming Keysight Technologies!

Effective August 1, 2014 all rights and obligations associated with this quotation and any subsequent order will be assigned to Keysight Technologies. The terms and conditions of the quotation and order will not change.

Purchase Orders issued prior to August 1, 2014 must be made to Agilent Technologies.

Purchase Orders issued on or after August 1, 2014 must be made to Keysight Technologies India Private Limited.

Step 2: When we publish this content the output comes in form of email in outlook. In outlook we notice that there's extra character after the end of the paragraph. The extra character is sometimes "<p>&nbsp;</p><" and sometimes only "<". In my previous comment I have pasted the outlook html sourcecode as well which shows the extra character as "&lt;"

Hope this helps.

comment:5 Changed 3 years ago by Reinmar

  • Resolution set to invalid
  • Status changed from pending to closed

Thanks for details.

It's very unlikely that it's CKEditor fault. If you see the correct content in the editor and if there's no &lt; character when the content is submitted (you can check this by switching to source mode), then CKEditor does the job correctly. It's a lot more likely that the tool which prepares the content for email has some bug.

I'm closing this issue for now. If you'll find that it's a purely CKEditor's fault and provide us a scenario how we can reproduce it locally, we can reopen the ticket.

comment:6 Changed 3 years ago by j.swiderski

@sumit please check what gets passed from CKEditor to your application (e.g. with Fiddler2). If there is no extra < then your application is adding this character somewhere or does bad job at trimming.

comment:7 follow-up: Changed 3 years ago by sumit

I have provided a workaround by removing <p> and </p> from the backend and hence the < is also removed. So to me looks like there's some bug with the CK editor where if the output is a mail to outlook with paragraph tags then it adds extra < at the end of paragraph. I agree with you it works well with IE but not with outlook mail.

comment:8 Changed 3 years ago by j.swiderski

I agree with you it works well with IE but not with outlook mail.

It may work in IE because IE may auto-fix it while outlook may not do same things as browser does.

<p> and </p> from the backend and hence the < is also removed

I data that is submitted doesn't contain "<" at the end then this is your backend working incorrectly. Instead of removing all <P> I would try to check your regexes or whatever you use to filter/change HTML because either it removes part of wrapping tag or doesn't remove whole tag.
This is area you should focus on.

comment:9 in reply to: ↑ 7 Changed 3 years ago by Reinmar

Replying to sumit:

I have provided a workaround by removing <p> and </p> from the backend and hence the < is also removed. So to me looks like there's some bug with the CK editor where if the output is a mail to outlook with paragraph tags then it adds extra < at the end of paragraph. I agree with you it works well with IE but not with outlook mail.

To verify whether there's a bug in CKEditor we need to see the content produced by it. Not the content processed by your system, Outlook or whatever else. We need the content directly from CKEditor. Only then we can verify if something is wrong with CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy