Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11944 closed Bug (invalid)

Inlinde editor on removed dom element error

Reported by: gcatalin Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: Reinmar

Description

Hi,

I have a backbone view where there is an inline editor. But if the view is closed right after the CKEDITOR.inline('editor') is called, but before it gets the element in the inline method, i get an "cannot read getEditor of undefined".

Can i somehow make it stop the inline method, cancel everything ? There is no instance created yet.

The error is on element.getEditor in the inline method. The dom element is removed and thus element is returned as undefined from the CKEDITOR.dom.element.get(element).

Change History (5)

comment:1 Changed 3 years ago by Reinmar

  • Keywords inline editor view element removed error removed
  • Status changed from new to pending
  • Version 4.3.2 deleted

How do you removed the view while synchronous code of CKEDITOR.inline is executed? It's impossible. Are you sure that the issue isn't somewhere else?

comment:2 Changed 3 years ago by gcatalin

Now that you mention it that does sound silly. I think i have a asynchronous handler somewhere. I'll see what i find. Please don't close the issue yet.

comment:3 Changed 3 years ago by gcatalin

It was actually an asynchronous issue. A colleague of mine setup the view incorrectly. Sorry for the unnecessary ticket.

comment:4 Changed 3 years ago by gcatalin

  • Resolution set to invalid
  • Status changed from pending to closed

comment:5 Changed 3 years ago by Reinmar

No problem. I'm glad you solved it :).

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy