Opened 3 years ago

Closed 3 years ago

#11945 closed Bug (fixed)

Forms plugin should not change core method

Reported by: Reinmar Owned by: pjasiun
Priority: Normal Milestone: CKEditor 4.4.2
Component: General Version:
Keywords: Cc:

Description

Forms changes element.prototype.hasAttribute. That should land in core, so it's covered with core tests.

Change History (5)

comment:1 Changed 3 years ago by Reinmar

  • Status changed from new to confirmed

comment:2 Changed 3 years ago by pjasiun

  • Owner set to pjasiun
  • Status changed from confirmed to assigned

comment:3 Changed 3 years ago by pjasiun

  • Status changed from assigned to review

I moved this code, added some tests and refactor hasAttribute, because it became messy.

Last edited 3 years ago by pjasiun (previous) (diff)

comment:4 Changed 3 years ago by a.nowodzinski

  • Status changed from review to review_passed

Rebased branch on master. Pushed a commit with minor refactoring.

comment:5 Changed 3 years ago by pjasiun

  • Resolution set to fixed
  • Status changed from review_passed to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy