Opened 10 months ago

Closed 3 months ago

#14542 closed Bug (fixed)

Copying numbered list from MS word doesn't keep list formatting

Reported by: pulkitg Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.6.0
Component: Plugin : Paste from Word Version: 4.5.2
Keywords: IE11 Support Cc:

Description

Steps to reproduce

  1. Create following type of bulleted list in MS Word
  1. Level1
  2. Level11
    1. level2
    2. level21
      1. Level3
      2. Level31
  1. Copy from word and paste into CKEditor window

Expected result

Bullet list should have same formatting when copied to CKEditor.

Actual result

List with 'a' and 'i' are also numbered as numeric.

Other details (browser, OS, CKEditor version, installed plugins)

Works fine in Chrome but doesn't work in IE11. Using latest version (i.e. 4.5.7) of CKEditor. Pastefromword plugin is also installed.

Attachments (3)

List in Word 2010.jpg (8.5 KB) - added by BobBeix 10 months ago.
List copied from MS Word 2010
Pasted list from Word in Chrome.jpg (14.9 KB) - added by BobBeix 10 months ago.
Result of paste into Chrome environment
Pasted list from Word in IE11.jpg (11.9 KB) - added by BobBeix 10 months ago.
Result of paste into IE11 environment

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 months ago by j.swiderski

  • Keywords IE11 added; bullet list formatting removed
  • Status changed from new to confirmed
  • Version changed from 4.5.7 to 4.5.2

There are two issues in fact. One with FF (reported here: #14544 ) and other with IE11.

Starting from CKEditor 4.0 (can be reproduced in even 4.0 although IE11 is supported from 4.3) lists were pasted as 1. <><><>. This issue was fixed in version 4.5.2 - #11376

Now, since CKEditor 4.5.2 list is pasted correctly but without any styles which should not be filtered.


Works fine in IE10- and Webkit/Blink.

Changed 10 months ago by BobBeix

List copied from MS Word 2010

Changed 10 months ago by BobBeix

Result of paste into Chrome environment

Changed 10 months ago by BobBeix

Result of paste into IE11 environment

comment:2 Changed 10 months ago by BobBeix

See the attachment images for details of what we're seeing today.

comment:3 Changed 10 months ago by pulkitg

Can someone please provide a tentative date by which this can be resolved. Thanks.

comment:4 Changed 10 months ago by pulkitg

If we copy numbered list from Word 2010, the HTML returned by editor.getData method encloses list item text into paragraph tag. At same time if we generate numbered list inside CKEditor itself then it doesn't enclose text in pragraph tags.

Can that be a sideeffect of original issue? If not, is there a way to avoid that? Thanks.

comment:5 Changed 10 months ago by j.swiderski

  • Keywords Support added

comment:6 Changed 10 months ago by m.lewandowski

The problem with paragraph being placed in list item in one case and not being placed in the other is a separate issue, at the same time it's a difficult one.

However the main subject of this issue could be resolved by #9991. @Tade0 could you check the branch if it fixes this issue?

comment:7 Changed 8 months ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to assigned

comment:8 Changed 8 months ago by Tade0

  • Milestone set to CKEditor 4.6.0

#9991 fixes this issue. Putting a milestone for it so we can officially close it once v4.6 is released.

comment:9 Changed 3 months ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from assigned to closed

It's fixed by #9991.

Fixed with git:f2af0353f8fb20231c7ca6de080c6cad273195eb merged to major.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy