Ticket #1635 (closed Bug: fixed)

Opened 7 years ago

Last modified 3 years ago

Find button report "The specified text was not found" even if text is in editor

Reported by: bongobongo Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: FCKeditor 2.5
Keywords: Cc:

Description

Hi.

The find button has finally gotten to work if you search for a word that is above the currrent cursor placement in the editor. That is nice.

But I do not understand why the find dialog have to report "The specified text was not found" when all occurences of a word has been found.

I would rather prefer either of the two below:

  1. If the last occurence of a word (does not need to be the last occurence of the word sought in editor though.... depends on where user has placed cursor in editor when hitting Find button in toolbar) has just been highligted in editor and user click Find button in Find dialog again then I would like the Find code to just highlight the next match in editor, no matter if it has been highlighted/found earlier.
  1. Or even better (maybe), is to display a message "All occurences has been found. Do you still want to continue searching.", if user click Find button in Find dialog after last occurence in editor has been highlighted. And if the user continue pressing the Find button.. then never display that message again (for same instance of the Find dialog that is).

So why do I want it to work that way? If you search for some text you might want to look at all occurences before deciding what to do. And let say you found 5 occurences and came to the last one, then why on earth should you have to close the current Find dialog and click Find button again, instead of just keeping to klick the Find button in the Find dialog.

Basically, prompting the enduser with "The specified text was not found" is not very informative if the text is present in the editor.

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added

comment:2 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to fixed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy