Ticket #1634 (closed Bug: fixed)

Opened 7 years ago

Last modified 3 years ago

Next element corrupted when delete key triggers removal of empty <P> tag.

Reported by: wizzydes Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: FCKeditor 2.5.1
Keywords: Cc:

Description

I have a document containing:

<p>&nbsp;</p><div contenteditable="false" class="wizard">{my wizard content}</div><p>&nbsp;</p>

I wish to remove the gap above my DIV, so I put the caret into the paragraph and start hitting the delete key.

When the paragraph is removed, the next element (the div) is converted to a bare paragraph. i.e. code becomes <p>{my wizard content}</p><p>&nbsp;</p>

This is rather alarming considering my CMS wizard generator plugin was fairly simple to get working.

NB) The problem only occurs when DisableEnterKeyHandler is false, so I assume that it's the actual DoDelete that's doing this.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added; delete convert div to p removed
  • Version set to FCKeditor 2.5.1

Confirmed.

In FF2 the bug occurs as in wizzydes description

In IE and IE7 pressing delete doesn't delete anything.

comment:2 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to fixed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy