Opened 5 months ago

Closed 5 months ago

#16817 closed Bug (fixed)

Paragraph transformed into lists, with corrupted data when pasting from Word

Reported by: m.lewandowski Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.7.0
Component: Plugin : Paste from Word Version: 4.7.0 (GitHub - major)
Keywords: Cc:

Description

Steps to reproduce

  1. Copy the text from attached docx to CKEditor demo page.
  2. The paragraphs are converted to list items and first word of paragraph is getting lost.

Expected result

Text simply gets pasted.

Actual result

Paragraph are transformed into lists, and first words are removed.

Other details (browser, OS, CKEditor version, installed plugins)

This content has been authored in MS outlook and pasted to word document.

Attachments (1)

SampleDocForDataLossBug.docx (12.0 KB) - added by m.lewandowski 5 months ago.

Download all attachments as: .zip

Change History (7)

Changed 5 months ago by m.lewandowski

comment:1 Changed 5 months ago by m.lewandowski

  • Status changed from new to confirmed

comment:2 Changed 5 months ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to assigned

comment:3 Changed 5 months ago by Tade0

The problem described here is caused by the fact that the check used to detect single level ordered lists(which take the form of single paragraphs) is too sensitive.

comment:4 Changed 5 months ago by Tade0

  • Status changed from assigned to review

Changing the criteria for single level ordered lists opened a whole nother can of worms.

Fortunately I was able to fix that without breaking anything else. One major takeout is now we can rely a little less on heuristics used to detect multi-level ordered lists in Edge.

Changes pushed to branch:t/16817.

comment:5 Changed 5 months ago by m.lewandowski

  • Summary changed from Paragraph transformed into lists, while corrupting data to Paragraph transformed into lists, with corrupted data when pasting from Word

comment:6 Changed 5 months ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from review to closed

Fixture for Edge was included but not used, so I added it to test suite - but the transformation for Edge was correct. There were some minor changes to the branch, other than that looks ok.

Pushed to major, merged wtih git:f8d2136e91.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy