Opened 9 years ago

Closed 8 years ago

#2066 closed Bug (fixed)

Safari : fullscreen mode doesn't work since Safari 3.1

Reported by: benjamin Owned by: martinkou
Priority: High Milestone: FCKeditor 2.6.1
Component: General Version: FCKeditor 2.6 RC
Keywords: Confirmed Safari Mac Review+ Cc:


With Safari 3.1 when I click on fullscreen button of FCK toolbar, my browser screen become all white and I can't write on it. The only things I can do is click on Back button of my Browser.

Browser: Safari 3.1 OS: Mac OS X Leopard 10.5.2

Attachments (1)

2066.patch (1.2 KB) - added by martinkou 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by w.olchawa

  • Keywords Pending WorksForMe added; safari 3.1 fullscreen removed

I can't reproduce this bug using the FCKeditor 2.6 and the latest SVN version on Safari 3.1 / Windows XP. This bug should be also checked on MAC.

comment:2 Changed 8 years ago by benjamin

ok, I test again with FCKeditor and the nightly build : It still not working.

Browser: Safari 3.1.1 OS: Mac OS X Leopard 10.5.3

comment:3 Changed 8 years ago by fredck

  • Keywords Confirmed Safari Mac added; Pending WorksForMe removed
  • Milestone changed from Safari Compatibility to FCKeditor 2.6.1

Confirmed with Safari 3.1.1 on Mac. This is definitely a serious issue.

comment:4 Changed 8 years ago by martinkou

  • Owner set to martinkou
  • Priority changed from Normal to High
  • Status changed from new to assigned

comment:5 Changed 8 years ago by martinkou

The fit window command worked in Safari 3.1/Mac for FCKeditor 2.4. It stopped working in 2.5. So some changes in between must have triggered this bug.

comment:6 Changed 8 years ago by martinkou

I've traced the code change that triggered to bug to r756. Still need more time to figure out why that breaks the fit window command though...

Changed 8 years ago by martinkou

comment:7 Changed 8 years ago by martinkou

The issue is found to be caused by a browser bug which happens only in Safari 3.1 for Mac. The workaround forces the browser to redraw FCKeditor's iframe before at some point when executing the Fit Window command so to make sure the graphical calculations that follow would be correct.

comment:8 Changed 8 years ago by martinkou

  • Keywords Review? added

comment:9 Changed 8 years ago by fredck

  • Keywords Review+ added; Review? removed

Oh.. that fix is really weird... for weird browser bugs.

Does it worth a ticket at the WebKit side?

comment:10 Changed 8 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

This bug is really weird, I've tried a bit today but I couldn't find a way to isolate the bug to a simple test case. Maybe I'll come back to this later.

Anyway, the bug is fixed with [2052].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy