Ticket #2250 (closed Bug: invalid)

Opened 6 years ago

Last modified 6 years ago

Error with convert tag nbsp while POSTing content

Reported by: tspider Owned by:
Priority: Normal Milestone:
Component: Server : PHP Version: FCKeditor 2.5.1
Keywords: Pending WorksForMe Cc:

Description

example "<p>1</p><p>2</p><p>3</p>", nothing error, content sending correctly, but if i insert in place "<p>1 &nbsp;</p>" after POST, content is break and i have in result only <p>1</p>, another part of content as "<p>2</p><p>3</p>" is absent!

Please help me with this trouble. I am looking this problem in all version 2.5 and higher

i am using a FireFox

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 6 years ago by tspider

Replying to tspider:

example "<p>1</p><p>2</p><p>3</p>", nothing error, content sending correctly, but if i insert in place "<p>1 &nbsp;</p>" after POST, content is break and i have in result only <p>1</p>, another part of content as "<p>2</p><p>3</p>" is absent!

Please help me with this trouble. I am looking this problem in all version 2.5 and higher

i am using a FireFox

sorry, i am forget, i see this code "[nbsp;" in content on output after POST

comment:2 in reply to: ↑ 1 Changed 6 years ago by tspider

Replying to tspider:

Replying to tspider:

example "<p>1</p><p>2</p><p>3</p>", nothing error, content sending correctly, but if i insert in place "<p>1 &nbsp;</p>" after POST, content is break and i have in result only <p>1</p>, another part of content as "<p>2</p><p>3</p>" is absent!

Please help me with this trouble. I am looking this problem in all version 2.5 and higher

i am using a FireFox

Another Example

i am copying some content from google insert into editor and "save", agter POST operation i see this [lt;img_class] => [quot;_height] => [quot;_alt] => [quot;_src] => [quot;_width] => [quot;

all tags in page as "&amp;" or "&nbsp;" or "&quot;" transform to this "[lt;img_class] => [quot;_height] => [quot;_alt] => [quot;_src] etc."

comment:3 follow-up: ↓ 4 Changed 6 years ago by w.olchawa

  • Keywords Pending WorksForMe added; nbsp, convert, POST, PHP removed

I've tried to reproduce your bug using FCKeditor 2.6 and the latest SVN version on FF2 and IE as well. In my case the output code works fine. The sample code: <p>1 &nbsp;</p><p>2</p><p>3</p> has the same output.

Please let me know if I'm missing something to reproduce this bug or possibly attach a screenshot of this bug.

Thanks in advance.

comment:4 in reply to: ↑ 3 Changed 6 years ago by tspider

Replying to w.olchawa:

I've tried to reproduce your bug using FCKeditor 2.6 and the latest SVN version on FF2 and IE as well. In my case the output code works fine. The sample code: <p>1 &nbsp;</p><p>2</p><p>3</p> has the same output.

Please let me know if I'm missing something to reproduce this bug or possibly attach a screenshot of this bug.

Thanks in advance.

i am loaded editor with ajax, and send data some code from editor

echo "<form method=\"POST\" name=\"editor\" action=\"javascript:makeRequest ('pages/save.php', 'cat_id=".$_POST[cat_id]."&subcat_id=".$_POST[subcat_id]."&doc='+document.editor.FCKeditor1.value, 'Content')">";

$sBasePath = '../fckeditor/';

$oFCKeditor = new FCKeditor('FCKeditor1') ; $oFCKeditor->BasePath = $sBasePath ; $oFCKeditor->Height = '500'; $oFCKeditor->Value = .$currentcontent; $oFCKeditor->Create() ; echo "</form>";

from ajax code

[cut] http_request.setRequestHeader("Content-type", "application/x-www-form-urlencoded"); http_request.setRequestHeader("Content-length", parameters.length); http_request.setRequestHeader("Connection", "close"); http_request.send(parameters); [cut]

if it is full ? or send another code & or full code ???

comment:5 Changed 6 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to invalid

The problem is that you aren't properly encoding your data. So it's a problem with your ajax that will fail also if you try to send that same content without using FCKeditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy