Ticket #2262 (closed Bug: worksforme)

Opened 6 years ago

Last modified 5 years ago

Creating a list from selection in gecko fails if starting from a blank page

Reported by: mcukstorm Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.6
Keywords: WorksForMe Cc:

Description

The Problem: When starting with a completely empty page and entering text then selecting and making it a list, the items are not put into a list but instead two spans are created with what look like protected source id's and the first item/line is deleted.


To replicate: Goto a page with the editor in, if there is default content in there goto source view and delete evereything the go back to wysiwyg mode. Enter a couple of lines of text, select them then click either the order list or unordered list toolbar items.


Results: Before list operation:

<p>test1</p>
<p>test2</p>
<p>test3</p>

After list operation:

<p><span style="display: none;" id="1213038742941S">&nbsp;</span></p>
<p>test2</p>
<p>test3</p>
<p><span style="display: none;" id="1213038743732E">&nbsp;</span></p>


Platforms I have tested this with firefox 2.0.0.14 & 2.0.0.12 on windows and linux with the same results, IE7 doesn't exhibit the same issue but i havent had a chance to test any other browsers.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Pending WorksForMe added; Empty List Span removed

I was unable to reproduce your bug both on FF and IE. I've used FCKeditor 2.6 and the latest SVN version and no problem has occurred. (you can test it on our demo page )What version of FCKeditor do you use? Could you provide more info about the circumstances in which the bug occurs?

Thanks in advance

comment:2 Changed 6 years ago by mcukstorm

Hello, contarty to my post you dont need to clear the contents out before either. If you enter some text in the editor, then do Ctrl+A to select everything, then click either the ordered or unordered list buttons and the previously described behaviour occurs.

Thanks

comment:3 Changed 6 years ago by w.olchawa

  • Version set to FCKeditor 2.6

I still can't reproduce this bug. I've done the test several times with and without clearing the cache and the result is always as expected.

comment:4 Changed 6 years ago by jonburney

I've tried this on the FCK demo too and had the same results.

The initial code I used in FCK was

<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

I then used CTRL-A to select all and then clicked the bulleted list icon, which produced the following HTML in FCK (you can see that one of the paragraphs has been removed and there are now three items

<p><span style="display: none;" id="1213186530111S">&nbsp;</span></p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>
<p><span style="display: none;" id="1213186530282E">&nbsp;</span></p>

Firebug displays the following error

K.parentNode is null
var FCKListCommand=function(A,B){this.Na...Node.replaceChild(J.listNode,A.root);}};
http://www.fckeditor.net/fckeditor/editor/js/fckeditorcode_gecko.js (line 78)

I'm using Firefox on Linux (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008060309 Firefox/3.0).

comment:5 Changed 6 years ago by fredck

  • Keywords Pending removed

comment:6 Changed 6 years ago by arczi

I can confirm this bug in 2.6 but it seems to be fixed in 2.6.3 Beta

comment:7 Changed 5 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to worksforme

works correctly in the current demo with Firefox 2 and 3.5b4

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy