Ticket #2280 (closed Bug: expired)

Opened 7 years ago

Last modified 6 years ago

Revision comparison bug (HTML passing into comparison rather than WikiText)

Reported by: levans Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: Pending WorksForMe Cc:

Description

I have noticed that FCKeditor seems to not work so well when reviewing versions after clicking 'undo' in the history for a page.

On the 'undo' screen MediaWiki compares 'Current revision' and 'Your Text'. 'Current revision' I assume come from the latest version of page in the database (WikiText) and 'Your Text' comes from the editor... the problem is that the content that is coming from the editor is HTML not WikiText (passing from WYSIWYG).

This makes it hard to compare and messy becuase 1 is WikiText and the other is HTML.

It is even worse when: 1) 2 users open the same page for edit at the same time 2) User 1 makes a change hits the save page button 3) User 2 makes a change and hits the save page button 4) User 2 gets a warning message saying that page has change since and give comparison... It will automatically update the editor with User 1's changes (latest version of page in database, which is WikiText). The problem is that the WikiText is put in the WYSIWYG not the 'WikiText' section.

Is there a fix for this? OR Is there any way to change the code so that the 'WikiText' is used rather than from FCKeditor WYSIWYG.

Any ideas/help appreciated!!

END NOTE: I also tested this by disabling the FCKeditor, worked fine because working with all WikiText.

Change History

comment:1 Changed 6 years ago by wwalc

  • Keywords Pending WorksForMe added; history, comparison, undo removed

Does it happen in the latest version of MW extension? I can't reproduce it on http://mediawiki.fckeditor.net/.

comment:2 Changed 6 years ago by fredck

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy