Ticket #2388 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

FCK fake objects are not copy-and-paste proof

Reported by: PavelZ Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: Cc:

Description

In both IE and FF:
Steps to reproduce

  1. insert pagebreak
  2. select part of text containing the pagebreak and copy it to the clipboard
  3. place cursor anywhere and paste from clipboar
  4. now there are two pagebreaks in the text
  5. press "Source" button twice
  6. only one pagebreak survived



In IE we are also able to get JavaScript error by following steps:

  1. insert pagebreak
  2. copy it to the clipboard
  3. press "Source" button twice
  4. paste the pagebreak from clipboard
  5. press "Source"

JS error "Permission denied" occures

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added
  • Version set to FCKeditor 2.6.3

Confirmed using FCKeditor 2.6.3 and the latest SVN version. I was unable to reproduce the second part of the ticket (JavaScript error).

comment:2 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy