Opened 7 years ago

Closed 7 years ago

#2387 closed Bug (fixed)

FF: Bulleted list error with CTRL+A

Reported by: PavelZ Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Firefox Review+ Cc:

Description (last modified by fredck)

Tested with Firefox/2.0.0.16, in the online demo.

With the following source:

<div>aaa</div>
<div>bbb</div>
<div>ccc</div>

In editing mode:

  1. select all (by pressing Ctrl+A)
  2. click "Insert/Remove Bulleted list"

A JS error is thrown and the first line of text is deleted.

Attachments (1)

2387.patch (1.2 KB) - added by martinkou 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by fredck

  • Description modified (diff)
  • Keywords Confirmed Firefox added
  • Milestone set to FCKeditor 2.6.3
  • Summary changed from Bulleted list does not work properly in FF to FF: Bulleted list error with CTRL+A
  • Version set to SVN

Confirmed with FF3 also. Ok with IE7, Opera and Safari. It happens with the following source also:

<p>aaa</p>
<p>bbb</p>
<p>ccc</p>

This one causes lost of data, so I'm targeting it the the 2.6.3.

comment:2 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

comment:3 Changed 7 years ago by martinkou

  • Owner martinkou deleted
  • Status changed from assigned to new

This seems to be FCKDomRangeIterator's problem.

If I use the following code for testing:

<div id="1">aaa</div>
<div id="2">bbb</div>
<div id="3">ccc</div>

And then add the following code just before line 93 in editor/_source/commandclasses/fcklistcommands.js:

alert(block.id);

And then perform the bug's test case. You'll see the id of 1 appearing twice. The duplicated block leads to the JavaScript error later.

comment:4 Changed 7 years ago by martinkou

The bug is found to be caused by lines 138 and 139 in fckdomrangeiterator.js - but the two lines are used to workaround the bug #1717.

Changed 7 years ago by martinkou

comment:5 Changed 7 years ago by martinkou

  • Keywords Review? added

comment:6 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

comment:7 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:8 Changed 7 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [2274].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy