Opened 7 years ago

Closed 7 years ago

#2412 closed Bug (fixed)

InsertHTML inserts at beginning of selection

Reported by: henrylyne Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: FCKeditor 2.6.3 Beta
Keywords: Confirmed Firefox Review+ Cc:

Description

This bug may be related to Ticket #2376. In FireFox 3 I see InsertHTML append to the beginning of a Selection, instead of replacing the Selection. Using FireFox 3 go through the same steps in ticket #2376.

Attachments (1)

2412.patch (454 bytes) - added by martinkou 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by martinkou

  • Keywords Confirmed Firefox added
  • Owner set to martinkou
  • Status changed from new to assigned

Confirmed. Happens in FF2 as well.

comment:2 Changed 7 years ago by martinkou

This is caused by the fix to #2247, the Gecko insertHtml logic doesn't delete the current selection before adding new content.

Changed 7 years ago by martinkou

comment:3 Changed 7 years ago by martinkou

  • Keywords Review? added

comment:4 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

Please include the changelog on commit.

comment:5 Changed 7 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [2308].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy