Ticket #2574 (closed Bug: invalid)

Opened 6 years ago

Last modified 6 years ago

paste generates multiple font tags in version 2.6.3

Reported by: bubach Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending Cc:

Description

hi, i've tried everything i can think of, but 2.6.3 still gives me:

<font><font size="3"> my text </font></font>

when i copy "my text" from a homepage in FF3 and paste it into FCKeditor 2.6.3 in another FF3 tab. I've tried to disable pastefromword and looked throught the source but can't find why it's doing this. i want plain text. :(

it was even more annoying to read in the forums that "no more font tags as standard from 2.5".. all i get is bloody font tags.

Change History

comment:1 Changed 6 years ago by arczi

  • Keywords Pending added

Did you try "Paste as plain text"?

Do you have <font><font size="3"> my text </font></font> in your homepage source?

comment:2 Changed 6 years ago by bubach

If I manually click paste as text it works, but I want to be able to use CTRL+V. No there's no font tags in the source of the html document I copied the text from.

FCKConfig.ForcePasteAsPlainText = true ;

Doesn't seem to be doing anything, the paste as word button is still visible and functioning, and CTRL+V still adds fotn tags to the text I try to paste.

And btw, I get the same thing on your site's demo of FCK editor (newest version). It doesn't generate font tags from all websites, only tried this one(no font tags) and the one I tried copying text from to begin with: http://www.fhdkompass.se/?FHD_Kassa

comment:3 Changed 6 years ago by arczi

Setting FCKConfig.ForcePasteAsPlainText = true; doesn't hide PasteFromWord button and it is not a bug.

You have FONT tag in your source (http://www.fhdkompass.se/?FHD_Kassa):

<td valign="bottom" colspan="3" width="910"><font size="5">FHD_Kassa</font></td>

but when ForcePasteAsPlainText is set to true you should see a "Paste as plain text" panel using CTRL+V.

comment:4 Changed 6 years ago by fredck

  • Status changed from new to closed
  • Resolution set to invalid

If you set ForcePasteAsPlainText to true, you will see the paste dialog in FF3 on CTRL-V or by using the Paste button. If you don't want the Paste from Word, just remove it from the toolbar.

FCKeditor does not "produce" font tags anymore by using its tools. It will not control it if you are taking content from outside the editor. If you had <font> in the source, the editor will just respect it.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy