Ticket #2575 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

Hitting carriage return cause the scrollbar to go at the end

Reported by: Perseides Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Firefox Cc:

Description (last modified by krst) (diff)

When using an html source that was previously generated by FCKEditor 2.3.1 with FCKEditor 2.6.3, hitting carriage return cause the scrollbar to go at the end of the box.

To reproduce, using Firefox 3, go to: http://www.fckeditor.net/demo, click the "Source" button, and paste this:

<p><font size="4"><font color="#008080"><strong><font color="#ff0000"><font color="#000080">Lorem</font></font></strong></font></font><font size="4"><font color="#008080"><strong><font color="#ff0000"><font color="#000080"><br />
</font></font></strong></font></font>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nulla ac velit. Etiam adipiscing pede vitae elit. Nam turpis odio, tristique ac, semper ut, malesuada nec, mi. Vestibulum tempus turpis a eros. Aenean feugiat metus ac tortor. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. In ultrices porttitor lorem. Ut posuere orci. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Suspendisse mattis.<font size="4"><font size="4"><font color="#008080"><strong><font color="#ff0000"><br />
<br />
Ipsum</font></strong></font></font><font size="4"><font color="#008080"><strong><br />
</strong></font></font></font>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nulla ac velit. Etiam adipiscing pede vitae elit. Nam turpis odio, tristique ac, semper ut, malesuada nec, mi. Vestibulum tempus turpis a eros. Aenean feugiat metus ac tortor. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. In ultrices porttitor lorem. Ut posuere orci. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Suspendisse mattis.<font size="4"><br />
<font size="4"><font color="#008080"><strong><br />
</strong></font></font></font><font size="4"><strong><font size="4" color="#000080"><font color="#ff00ff"><font color="#008080"><font color="#993366"><font color="#ff6600"><font color="#008080"><font color="#ff0000"><font color="#000080">Lorem</font></font></font></font></font></font></font></font></strong><strong><font size="4" color="#000080"><font color="#ff00ff"><font color="#008080"><font color="#993366"><font color="#ff6600"><font color="#008080"><font color="#ff0000"><br />
</font></font></font></font></font></font></font></strong></font>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Nulla ac velit. Etiam adipiscing pede vitae elit. Nam turpis odio, tristique ac, semper ut, malesuada nec, mi. Vestibulum tempus turpis a eros. Aenean feugiat metus ac tortor. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. In ultrices porttitor lorem. Ut posuere orci. Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Suspendisse mattis.<font size="4"><strong><font size="4" color="#000080"><font color="#ff00ff"><font color="#008080"><font color="#993366"><font color="#ff6600"><font color="#008080"><font color="#ff0000"><br />
</font></font></font></font></font></font></font></strong></font></p>
<p>&nbsp;</p>

Then, click "Source" again. Go at the top of the red "Ipsum" title, and hit carriage return. The scrollbar will move to the end of the box.

Change History

comment:1 Changed 6 years ago by Perseides

  • Milestone FCKeditor 2.6.4 deleted

comment:2 Changed 6 years ago by arczi

  • Keywords Confirmed Firefox added
  • Version changed from FCKeditor 2.6.3 to FCKeditor 2.4

Confirmed in FF, in IE7 works fine. To reproduce set editor height to 200px

comment:3 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme
  • Description modified (diff)

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy